Announcement

Collapse
No announcement yet.

Need help with icons

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Need help with icons

    hello i am an experienced modder with 7 and im having issues loading my icons into the game.

    i followed the path instructions

    E:\Steam Library\steamapps\common\7 Days To Die\Mods\MYmod\UIAtlases\ItemIcons

    The Game starts up and says

    Wrn: creating new atlas for MYmods(1)

    but when i start the game all i get is a blank space

    i have tryed the old resolution, (116x80) and the new one (160x160)

    #2
    The proper path is actually
    Code:
    Mods/YourModName/UIAtlases/ItemIconAtlas
    The information in the release notes is inaccurate and should be corrected.

    Thanks to Khaine for the proper info!

    Comment


      #3
      Originally posted by TSBX View Post
      The proper path is actually
      Code:
      Mods/YourModName/UIAtlases/ItemIconAtlas
      The information in the release notes is inaccurate and should be corrected.

      Thanks to Khaine for the proper info!
      E:\Steam Library\steamapps\common\7 Days To Die\Mods\ButcherMod\UIAtlases\ItemIconsAtlas

      Still wont work what are the required dimensions

      am i doing something wrong

      Comment


        #4
        Icon should be:
        • A .png
        • 160px x 160px
        • Located in Mods/YourModName/UIAtlases/ItemIconAtlas

        Hope this helps.

        Comment


          #5
          https://discord.gg/rHSQ7V2 new mod butcher update

          Comment


            #6
            As of A18, icons can be any size, but preferably a square, so that the height and width is the same.

            Comment


              #7
              Its ItemIconAtlas not ItemIconsAtlas

              Took me 1H to find the typo myself ;p

              Comment


                #8
                Does anyone know if this works for the UI icons?

                For instance:

                E:\Steam Library\steamapps\common\7 Days To Die\Mods\MYmod\UIAtlases\UIAtlas

                Comment


                  #9
                  from patch-notes for a18:
                  XUi: Reworked adding/overriding UI sprites. ItemIcons now go to “<mod>/UIAtlases/ItemIcons”. The new system can also be used for the regular UIAtlas that is used with generic XUi sprites (“<mod>/UIAtlases/UIAtlas”) or completely new custom sprite atlases (any other folder name in UIAtlases). Added sprites can be any size (a sensible limit would be 1024×1024 though) and aspect ratio. Created atlases are dumped to disk for inspection when the game is ran with the argument “-exportcustomatlases”

                  Comment


                    #10
                    So does that mean we can easily add new buff icons and other sprites now?

                    Comment


                      #11
                      Yep.

                      Comment


                        #12
                        I really don`t know what im doing bad. I tried everything, every example of name folder. Still ive got empty window for addon item. Im making simple Auger. Maybe there is something wrong in items file, code is that:

                        <property name="CustomIcon" value="DiamondAuger"/>

                        so should be okay. Obviously .png file is same like value for CustomIcon.

                        Comment


                          #13
                          Originally posted by revolvolution View Post
                          I really don`t know what im doing bad. I tried everything, every example of name folder. Still ive got empty window for addon item. Im making simple Auger. Maybe there is something wrong in items file, code is that:

                          <property name="CustomIcon" value="DiamondAuger"/>

                          so should be okay. Obviously .png file is same like value for CustomIcon.
                          Icon should be:
                          • A .png
                          • 160px x 160px
                          • Located in Mods/YourModName/UIAtlases/ItemIconAtlas

                          The icon name spelling and capitalization must match the name in the xml property exactly.

                          Comment


                            #14
                            Originally posted by xyth View Post
                            Icon should be:
                            • A .png
                            • 160px x 160px
                            • Located in Mods/YourModName/UIAtlases/ItemIconAtlas

                            The icon name spelling and capitalization must match the name in the xml property exactly.
                            Its exectly same in xml file like a name of .png file. Im out of ideas. Every three points that you reminded match. Its A.png, 160x160, location is /Mods/DiamondAuger/UIAtlases/ItemIconAtlas

                            Comment


                              #15
                              Ok, so i found out problem exist only in my dedication server. I uploaded mod to single-player game, and icon is working. Any ideas what is the problem? I add that if change icon value to any of stock 7 days to die icons, its working on my server. Only my own, custom icons not working.

                              Comment

                              Working...
                              X