Announcement

Collapse
No announcement yet.

RWGmixier and prefabs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    RWGmixier and prefabs

    I currently have 5 prefabs i am trying to make spawn with the rwgmixier. For some reason 2 of them work and 3 don't. There is no reason the 3 should not be working. I have read over tons of posts about prefabs and have yet to find something on this issue. Anyone have any thoughts or is anyone else having this type of problem? Sadly i am out of town for 2 weeks but would love to fix this when i get back. Thank you everyone.

    #2
    Hello, can you share the prefabs? i would like tho make some tests.

    Comment


      #3
      Finally got to a comp while on vication
      Here are the prefabs

      Library.zip This is a prefab i saw in a you tube video and picked it up to put into my random worlds. It will not generate into the world....

      davehome.zip This is my first prefab i built from scratch and it works great appering in the world often.

      DMC_lostjoels.zip I dont like having traders in my games so I altered this Traders compound very slightly and it appers often in the random worlds.

      DMC_Adamhome.zip & DMC_Adamhome_part2.zip This prefab had to be broken into 2 parts. This is the 2nd prefab i built from scratch. This prefab is not appering in the world and is thus not working in random worlds.

      Comment


        #4
        DMC_cliffdwelling.zip & DMC_Cliffdwellingpart2.zip This prefab is the cliffdwellings from the game altered to fit into a random world. It does not generate into a random world.

        Hopefully this helps. Below is the xml i have been using to put the prefabs into the rwgmixer
        rwgmixer.zip

        Please let me know what you think and if you can see why 2 of them apper in random worlds and 3 dont
        Attached Files

        Comment


          #5
          Code:
            <daveworld>
          
          	<insertAfter xpath="/rwgmixer/prefab_rules/prefab_rule[@name='townGroup']/prefab[@rule='residentialNewGroup']">
          		<prefab name="DMC_Adam_House_Z1"/>
          	</insertAfter>
          	
          	<remove xpath="/rwgmixer/prefab_rules/prefab_rule[@name='wildernessGroup']/prefab[@name='settlement_trader_01']">
          	</remove>
          	<remove xpath="/rwgmixer/prefab_rules/prefab_rule[@name='wildernessGroup']/prefab[@name='settlement_trader_02']">
          	</remove>
          	<remove xpath="/rwgmixer/prefab_rules/prefab_rule[@name='wildernessGroup']/prefab[@name='settlement_trader_03']">
          	</remove>
          	<remove xpath="/rwgmixer/prefab_rules/prefab_rule[@name='wildernessGroup']/prefab[@name='settlement_trader_04']">
          	</remove>
          	<remove xpath="/rwgmixer/prefab_rules/prefab_rule[@name='wildernessGroup']/prefab[@name='settlement_trader_05']">
          	</remove>
          	
          	<insertAfter xpath="/rwgmixer/prefab_rules/prefab_rule[@name='downtownGroup']/prefab[@name='business_old_08']">
          		<prefab name="_Library_POI"/>
          	</insertAfter>
          	
          	<insertAfter xpath="/rwgmixer/prefab_rules/prefab_rule[@name='wildernessGroup']/prefab[@name='cabin_15']">
          		<prefab name="Dave_Home_2"/>
          		<prefab name="DMC_Lost_Joels"/>
          		<pregab name="DMC_Cliff_Dwelling"/>
          	</insertAfter>
          	
          	
          	<insertAfter xpath="/rwgmixer/prefab_rules/prefab_rule[@name='oldResidential_Bldgs']/prefab[@name='house_old_victorian_12']">
          		<prefab name="DMC_Adam_House_Z1"/>
          	</insertAfter>
          	
          	
          	<insertAfter xpath="/rwgmixer/prefab_rules/prefab_rule[@name='residentialNew_Bldgs']/prefab[@name='house_construction_02']">
          		<prefab name="DMC_Adam_House_Z1"/>
          	</insertAfter>
          	
          </daveworld>
          And i added a max/min count to test, if u want it helps
          Code:
           	<insertAfter xpath="/rwgmixer/prefab_rules/prefab_rule[@name='wildernessGroup']/prefab[@name='cabin_15']">
          		<prefab name="Dave_Home_2" min_count="1" max_count="3" prob="2"/>
          		<prefab name="DMC_Lost_Joels" min_count="1" max_count="2" prob="2"/>
          		<prefab name="DMC_Cliff_Dwelling" min_count="1" max_count="1" prob="10"/>
          	</insertAfter>
          you just writed wrong, PREGAB instead of PREFAB, and the DMC_Adam_House_Z1 is missing ID mapping files, i cant load this in my world and i get alot of errors when placing this on RWG the others are working fine. hope it helps!!

          Comment


            #6
            here how it looks in game, you should change the desert terrain to terrain filler (POI) this one are in DEV blocks

            Comment


              #7
              Thank you for looking it over. Interesting I never got an error with that miss spelling. Also did you get the library prefab working?

              Comment


                #8
                in my experience with RWGmixer
                if your "terrain hiegth" + "prefab hiegth" > 255, it will not spawn, it will show the distant mesh, and in the world preview, but not when you get near
                on that same note if "terrain sublevel" - "prefab sublevel" < 0, it will not spawn in.

                this bit of info was one of the hardest bugs i had making EPIC CITIES
                hopefully it will asist you in debugging your issue,

                is this for a17.3s?
                also let me know if you still need help, i would be happy to look through the prefab.xml and make sure townships and biomes, and rwg are enabled.

                Comment


                  #9
                  I have manged to get it all working thank you, and they were 17.2

                  Comment

                  Working...
                  X