Announcement

Collapse
No announcement yet.

Compo-Pack for Random Gen

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by stallionsden View Post
    Yeh the in game mesh creator is bugged as hell . I will be using the commands from now on to do the meshes of my prefabs which pille pointed out to me. They are as follows -

    Open the console and enter the commands -
    prefab simplify
    prefab combine
    prefab export
    to generate the mesh.

    Maybe all us prefabbers should use the commands and not the update imposter function of the in game prefab editor.

    Note for mags to I guess
    tbh I never knew that a ingame-mesh-creator exists

    Almost all meshes were created via-console-comands
    (All A16-meshes were created with Hal's "meshall"-command and most of the new A17-meshes were created by me also in the console)
    When I took prefabs in A17 that already had meshes I dont produced a mesh for that prefab ofc (maybe I should)

    But there is another problem relating to that Issue I talk about in the next post....

    Comment


      Originally posted by PixieWal View Post
      Hey Guys,
      I'm having a similar experience to this video. I have odd looking blocks appear and where walls, etc get destroyed...for me I still cannot see that they are gone.

      I've followed all instructions to install the compo-pack on the client side. I'm on a friends server who does not experience the same as me.
      Any suggestions on a fix? have a look here - https://www.youtube.com/watch?v=a8ivmSC1j-0
      thx for the feedback

      ... I saw the video - the first thing I saw inner secund is the textures are looking really really wierd in that video, thats a fact !

      The prefab in this video is xcostum_SuperStore(by_Volar)

      And this is the first part that makes me curios, because this prefab is very old. It never had Issues with the meshfile in A16 and A17.
      It also shows up perfect in my actual A18.2 game - and also went through it in my 18.1-survival
      Didnt had any Issues at all (MAYBE BECAUSE I PLAY SP !!!!!?????!!!!!)

      The meshfile is still the same like it was since meshes was introduced to the game.
      I think all of the cases i know of are belonging to MP-maps when I remember right.

      SO considring all of that I dont think this is a MESH-ISSUE !!!

      IMO this is a network- aka MP-Issue and has something to do with the datas streaming from host (server) to client !!!

      Iam pretty sure there is also a bug in the texture-streaming-engine at all (also in SP !!!)


      It should be adressed to TFP thou

      (if its not ur gxfcard, gfx-settings or directX-driver Issues)(got newest gxf-driver installed ???) but guess not<<
      Last edited by Magoli; 12-20-2019, 10:21 PM.

      Comment


        Originally posted by Magoli View Post
        tbh I never knew that a ingame-mesh-creator exists

        Almost all meshes were created via-console-comands
        (All A16-meshes were created with Hal's "meshall"-command and most of the new A17-meshes were created by me also in the console)
        When I took prefabs in A17 that already had meshes I dont produced a mesh for that prefab ofc (maybe I should)

        But there is another problem relating to that Issue I talk about in the next post....
        Fair point I use the in game mesh creator (also known as update imposter) and this occurs with mine so yeh I will be redoing all my prefabs meshes using the console commands. But the textures one I think you are correct with the issue being MP related as that isn't what I need either with that prefab. But the doors being like that is a mesh issue whether it be game bug or what not that is the mesh showing. Let's hope tfp address this tho soon

        Comment


          Magoli if youd consider adding my new prefabs that would be cool, ignore my sense of humor as 1 of them is a Brutal/Insane Prefab called Auschwitz_Camp_B over 70 z's that all spawn at different moments.. But interesting Loot if you survive & dont cheat..

          Mentioned it cos it doesnt get refreshed due to the comments being saved at the start...

          Comment


            guys.. about the visible walls that doesnt exist (the two POIs I showed), I dont get the result. Should I just remove it from the list of prefabs? If I keep it and update compo pack once its fixed, will it fix in an existing world?

            Comment


              Originally posted by danielspoa View Post
              guys.. about the visible walls that doesnt exist (the two POIs I showed), I dont get the result. Should I just remove it from the list of prefabs? If I keep it and update compo pack once its fixed, will it fix in an existing world?
              prefabs in visited regions will stay
              prefabs in unvisited regions will spawn as they actual are (with all the saves being made since it was saved by a editor last time)

              when u delete the regionfiles all prefabs will spawn new
              (caution to not remove the region ur base is in !!!)

              Comment


                Sure, thanks!
                last question.. I'm wiping the server, is there a new version on the horizon?

                Comment


                  Originally posted by danielspoa View Post
                  Sure, thanks!
                  last question.. I'm wiping the server, is there a new version on the horizon?
                  early/mid January i guess

                  Comment


                    gonna just remove these two pois then
                    thanks for the amazing work

                    Comment


                      Thanks for all the hard work all have put into this POI pack.
                      I added it to my server, and used with a Nitrogen Map, and it's like a whole new world now.
                      The new POI's are fantastic, and you can see that they are the work of many actual gamers that view the game in their unique way.

                      Comment


                        Originally posted by danielspoa View Post
                        I recorded it so u can have a better idea of what I'm facing. PLEASE excuse my English.
                        I thought about video settings but two other players went there and saw the same

                        it happens in both airport pois, both have tier 5 quests. Also, the quest exclamation point in the airport didn't appear, nor did the satchel position in airport2 (the military thing).

                        thank you for the amazing work tho!!

                        edit: video link https://www.youtube.com/watch?v=IdBo_YnUdmE
                        It seems that you guys are aware of the mesh issue. I can make this go away if I stay at the poi, log out and log back in it's fixed but once others load some will show up with problem. Kind of sucks the pack looks cool. I'm doing a SP run have a 970 gtx if that helps.

                        Comment


                          My friend hates playing with mods but i have my own singleplayer game and i was wondering what would happen if i have mods installed like this that he doesnt when i join his game? Will the mod just not take affect or will it mess stuff up

                          Comment


                            Originally posted by tony979 View Post
                            My friend hates playing with mods but i have my own singleplayer game and i was wondering what would happen if i have mods installed like this that he doesnt when i join his game? Will the mod just not take affect or will it mess stuff up
                            normaly ur friend has at Least to copy the CP-prefabs into his prefabs-folder

                            If he dont do it he will get a wall of red Messages, but only the first time he joins
                            When he quits and rejoins he will be fine to play than (because the 2nd time the engine will get the needed datas from the server - and in the future he will have his own save to get the datas)

                            ^^this is a (rude) tricky way to show ur friend what this mod does

                            Comment


                              Mags

                              Do you know that xpath now allows you to place prefabs in the prefab folder via xpath in your mods folder.

                              If ya need a example check out my prefablets....

                              Credit to chiko` for this info

                              Comment


                                Originally posted by stallionsden View Post
                                Mags

                                Do you know that xpath now allows you to place prefabs in the prefab folder via xpath in your mods folder.

                                If ya need a example check out my prefablets....

                                Credit to chiko` for this info
                                no I didn't know that

                                tbh I also dont know what is xpath (in detail)
                                (I know it has something to do with modlets and these strange mod-folders which are out there)

                                maybe this has something to with some of the Issue-Msgs I got here in the thread.
                                (maybe people copied the prefab-files somewhere, but not into the prefabsfolder where they supposed to be)
                                (maybe prefabfiles are in both folders twice (prefabs and xpath) and this maybe makes problems) - idk!

                                But anyhow - COMPOPACK has nothing to do with all that stuff
                                (CP just belongs to the prefabsfolder because of the prefabfiles, the configfolder because of the rwgmixer.xml, and optional the generated-worldsfolder for Nitrogen-maps - thats all)

                                Everything else is not sure fire IMO

                                Comment

                                Working...
                                X