Announcement

Collapse
No announcement yet.

A16 - 7DaysProfileEditor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    Hello! Please excuse my newbness, but how do I install this? I went to the link, and found the files, and downloaded it, but there is no install routine, nowhere to pay to get one, no readme file to explain. Can you help me? Thanks!

    Comment


      #32
      The GitHub link was broken.

      The GitHub link now works.

      It will point you to a folder with an .exe file and .dll file. Download both and run .exe.

      Comment


        #33
        Many thanks Karlovsky. I lost my game profile due to an electricity outage last night. I was on day 32, and had just gotten myself a fine minibike and was about halfway through building a huge zombie trap. I couldn't believe it when the game dropped me into nowhere with nothing at level 1. You have made my day.

        Comment


          #34
          Glad I could help. If you think the tool lacks anything, feel free to say and I'll see what I can do.

          Comment


            #35
            Hi, I'm having some issues attempting to get this to work.

            1. I have both the .exe and .dll files in the same folder, as instructed.
            2. Launched .exe, then navigated to the 7daystodie game root folder
            3. Tool opens, I navigate to my MP save file in my appdata folder and open the .ttp
            4. Play around with some values, and attempt to save
            5. This error appears: http://imgur.com/a/G4Lzv

            Am I doing something wrong? Much thanks.

            Comment


              #36
              Aw crap. I've added a few classes in the latest release and forgot to mark them as serializible.

              I should really work on my testing habits (as in actually do it every once in a while).

              I'll have it fixed as soon as I can (about 18h or so from now (sorry)).

              Also, does the thread subscription thingy on the forum ever work properly? I was lucky enough to be notified this time, albeit 23h to late...

              EDIT: I fixed it yesterday, forgot to post it here.
              Last edited by Karlovsky120; 04-21-2017, 08:35 AM.

              Comment


                #37
                Originally posted by Karlovsky120 View Post
                Aw crap. I've added a few classes in the latest release and forgot to mark them as serializible.

                I should really work on my testing habits (as in actually do it every once in a while).

                I'll have it fixed as soon as I can (about 18h or so from now (sorry)).

                Also, does the thread subscription thingy on the forum ever work properly? I was lucky enough to be notified this time, albeit 23h to late...

                EDIT: I fixed it yesterday, forgot to post it here.
                I still have this problem....

                Comment


                  #38
                  Originally posted by Karlovsky120 View Post
                  Aw crap. I've added a few classes in the latest release and forgot to mark them as serializible.

                  I should really work on my testing habits (as in actually do it every once in a while).

                  I'll have it fixed as soon as I can (about 18h or so from now (sorry)).

                  Also, does the thread subscription thingy on the forum ever work properly? I was lucky enough to be notified this time, albeit 23h to late...

                  EDIT: I fixed it yesterday, forgot to post it here.
                  Thanks for your time and great work, I'll check it out soon and report back!

                  Comment


                    #39
                    Originally posted by Anhnalex View Post
                    I still have this problem....
                    I screwed up, again, fixed it, it really, REALLY, should be working now.
                    Last edited by Karlovsky120; 04-24-2017, 10:31 AM.

                    Comment


                      #40
                      Any idea how I can make this work with my Starvation modded save? I have a copy of my game in a separate folder with the XMLs, but when I try and load the exe for the tool to use, it instantly gives me an 'object was not set to an instance of an object' exception and crashes.

                      I'll see if I can get the crash log out to you later on (if it's possible)

                      All I literally want to do is tick back the number of deaths from 5 to 4 on my save

                      Comment


                        #41
                        Hmm, since it crashes on startup, something must be amiss with the XMLs. Either I missed something, or the mod's doing something quirky with them.

                        Either way, I'm gonna have to see them to fix the problem. blocks, items and progression are the ones I need.

                        Upload them somewhere and send me a link.

                        P.S. I wanted to change my death count from 1 to 0. I couldn't, so I created this tool.

                        Comment


                          #42
                          Karl, if you're tapping into the assembly-csharp.dll for your editor, the starvation mod edits it, so that may be the cause of his particular problem.

                          Purely guessing. Been following this thread with interest.

                          Comment


                            #43
                            Here's a link to my XMLs and save data... I hope it can be fixed If not... guess I'll have to try making a new character, get the skills up manually, and re-copy him across.

                            https://www.dropbox.com/sh/hd18xw9lw...6BtLDtYHa?dl=0

                            Comment


                              #44
                              Originally posted by mdf25 View Post
                              Here's a link to my XMLs and save data... I hope it can be fixed If not... guess I'll have to try making a new character, get the skills up manually, and re-copy him across.

                              https://www.dropbox.com/sh/hd18xw9lw...6BtLDtYHa?dl=0
                              Is this on a dedi or sp/mp game?

                              Comment


                                #45
                                I figured it out. It's this item:

                                Code:
                                <item id="1579" name="flyer">
                                	<property name="Extends" value="schematicMaster" />
                                	<property name="EconomicValue" value="50" />
                                	<property class="Preview">
                                		<property name="Zoom" value="10" />
                                		<property name="Pos" value="0,-0.2" />
                                		<property name="Rot" value="90,45,0" />
                                	</property>
                                </item>
                                It extends schematicMaster, and I assume that any item that extends it has Action1 defined, and that within it has Recipes_to_learn defined. Which they always do, at least until now.

                                This one doesn't, so I get a null reference exception. The modder broke the xml rules, and I do not intend to implement code to check for this specific case. Any schematic that inherits schematicMaster must implement some kind of recipe, even if it's just a blank list.

                                However, if you comment this line out:

                                Code:
                                <property name="Extends" value="schematicMaster" />
                                the program will work. The flyer item will probably work fine within the program with the line commented out (you'll be able to place it in the inventory and remove it), but make sure you revert it before playing the game.

                                Alternatively, you could suggest to the mod creator to add this property to the item:

                                Code:
                                <property class="Action1">
                                	<property name="Recipes_to_learn" value="" />
                                </property>
                                I don't think it will change how the item behaves in any way, but the item won't be breaking any rules anymore.

                                Originally posted by Guppycur View Post
                                Karl, if you're tapping into the assembly-csharp.dll for your editor, the starvation mod edits it, so that may be the cause of his particular problem.

                                Purely guessing. Been following this thread with interest.
                                I don't access the assembly-csharp.dll with the program, but any mod that changes it might change the defined rules my program works off, which in turn might end up in a crash. The same thing with the xmls, if they go outside the defined rules, really. I don't really see the point of that item extending schematicMaster.

                                Oh, and I'm really glad people are interested in this project.
                                Last edited by Karlovsky120; 04-26-2017, 11:02 PM.

                                Comment

                                Working...
                                X