No announcement yet.

SDX Persistent Arrows

  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by HAL9000 View Post
    This version isn't but the A15 one is lurking in the shadows waiting for the RC of SDX 7 (which is the version A15 will need)
    Oh ok, that explains the errors I was getting. How long till RC of SDX 7 allows this awesome looking mod to see the light again?


      Not sure, couple of more things to get into the patching system then I think it's good to go but Dom is busy with RL so it's just when he gets round to it.


        Update Time!

        A15 compatible version (SDX 0.7) in the OP


          Get an error trying to compile:
          c:\SDX_0.7.0\Targets\7DaysToDie\Mods\HalArrows\Scr ipts\ProjectileMoveScriptArrow.cs(190,21): error CS0103: The name 'HalHelperEvents' does not exist in the current context


            Ah yeah, this now need the helper mod I've done to work so it'll be compatible with the fire mod when it's released. I've added a link to the OP.



              Wrong thread!


                Can someone please confirm, that this mod runs on a server?
                Having troubles getting this to run. Can shoot the arrow and the arrow is also a pickable item when shot. But can't actually pick it up.


                  Dont work for me on my server
                  do's the same for me
                  also the turret mod is the same
                  It seems if you need to press the E key for a mod it wont work
                  Last edited by oakraven; 01-06-2017, 10:03 PM. Reason: spelling


                    I don't think the mods work on MP. I'm still in the process of creating ways for mods to sync over MP. Sometimes you can use the same methods that vanilla uses so there's no problem but if you want custom behaviour it needs to be written in. Once a nice way has been found I'll update the mods for MP


                      Hey hal for some reason A15 and halhelper both throw warnings with my security? Claims some thing in the files. Any idea whats up? havent had this happen before.


                        It'll be the credit card stealing code I added in the last update. That, or a false positive. Feel free to upload the file to some online checkers to get a second opinion if you're worried.


                          Originally posted by HAL9000 View Post
                          It'll be the credit card stealing code I added in the last update. That, or a false positive. Feel free to upload the file to some online checkers to get a second opinion if you're worried.


                            hi i downlaoded the mod and the hal dlls and when compile i get an error that says sdx launcher stop working , after that error disappear an compile the mods..

                            ingame i can pickup arrows after shoot them but from second arrow shot i dont see bow animation anymore but only bow cursor

                            tried other mods and comple works fine..

                            any hint??

                            a15 and sdx 0.7.0
                            Last edited by JC LEON; 03-21-2017, 09:36 AM.


                              If you wait for the compile to finish and scroll up you'll see the error that was thrown


                                ths is the error on sdx message when it stops working

                                Stopped working

                                File che contribuiscono alla descrizione del problema:
                                C:\Users\Labor\AppData\Local\Temp\WER1334.tmp.WERI nternalMetadata.xml

                                Leggere l'informativa sulla privacy online:

                                Se l'informativa sulla privacy online non รจ disponibile, leggere quella offline:

                                and this is the error zone on compile log after sdx finished

                                EVENT: Begin task: Patch localization
                                PatchFile: C:\Users\Labor\Desktop\SDX_0.7.0/Targets\7DaysToDie\Mods\HalDllUpdates\Text/Localization.txt

                                Eccezione non gestita: System.IndexOutOfRangeException: Indice oltre i limiti della matrice.
                                in SevenDaysToDiePlugin.LocalizationTable.AddRow(Stri ng[] newColumns, String[] newRow)
                                in SevenDaysToDiePlugin.LocalizationTable.Merge(Local izationTable table)
                                in SevenDaysToDiePlugin.CompileLocalizationPatchTask. PatchTextFile(String sourcePath, String destPath, String patchFilePath)
                                in SevenDaysToDiePlugin.CompileLocalizationPatchTask. Execute()
                                in SevenDaysToDiePlugin.Plugin.RunTasks(List`1 tasks, CompilerConfig config)
                                in SevenDaysToDiePlugin.Plugin.RunAction(String action, CompilerConfig config)
                                in SDXC.Program.Run(SDXCompilerSettings settings)
                                in SDXC.Program.Main(String[] args)

                                i tried on two different machines and sdx crash always during compile

                                tried with working beds from Cartzilla and compile works fine and mod too
                                Last edited by JC LEON; 03-21-2017, 03:45 PM.