Announcement

Collapse
No announcement yet.

SDX Persistent Arrows

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #46
    That's a bug with SDX and 15.2.

    You can either delete the localisation file in the HalDLLUpdates (it's not needed) or to fix it for any mod that has a localisation file you need to open the file in <SDX_LOCATION>\Backups\7 Days To Die\Data\Config\Localization.txt in notepad++ and then change the Encoding from UTF8-BOM to UTF8

    Comment


      #47
      Originally posted by HAL9000 View Post
      That's a bug with SDX and 15.2.

      You can either delete the localisation file in the HalDLLUpdates (it's not needed) or to fix it for any mod that has a localisation file you need to open the file in <SDX_LOCATION>\Backups\7 Days To Die\Data\Config\Localization.txt in notepad++ and then change the Encoding from UTF8-BOM to UTF8


      THanks it worked.. i deleted the localzation file in the haldllupdates and compiles worked correclty without any errors..but i have the same weird bug like before..

      for first shoot bow animation works correctly butafter i shoot the first arrow, bow shoot animation dont work anymore

      Comment


        #48
        Sounds like a conflict between mods. Check your log files for errors when you're running the game

        Comment


          #49
          i dont have any other mod installed ,only haldll and persistent arrow on allpha 15.2 b8 and sdx 0.7.0 ,,the problem is present even in a clean version of 7d2d on two different machines

          Comment


            #50
            Then alas, it sounds like A15.2 broke the mod. I'll update the OP, thanks

            Comment


              #51
              many thanks to you for your support and effort... let me know when all is updated..i love this mod...thanks again...

              Comment


                #52
                Such a simple feature, but adds so much depth to archery and sets it apart from other ranged weapons, I feel somewhat annoyed that this isn't a thing in vanilla 7dtd.
                Last edited by Xamllew; 03-25-2017, 09:24 PM.

                Comment


                  #53
                  Update Time!

                  Added: A16 support

                  Comment


                    #54
                    Dl links for A16 seems to be broken :/

                    Comment


                      #55
                      Links are ok but the server the files are hosted on just had a wobble, try again

                      Comment


                        #56
                        Jup, working now.

                        Comment


                          #57
                          @Hal: Does this work on an SDX server? It works fine in our SDX SP/MP build, but on the server, the arrows remain in the target as expected, but cannot be recovered. The "E" prompt shows, but does not recover the arrow. Occasionally, it seems to almost work, but the client side throws this error:

                          ArgumentException: An element with the same key already exists in the dictionary.
                          at System.Collections.Generic.Dictionary`2[System.Int32,Entity].Add (Int32 key, .Entity value) [0x00000] in <filename unknown>:0
                          at DictionaryList`2[System.Int32,Entity].Add (Int32 _key, .Entity _value) [0x00000] in <filename unknown>:0
                          at World.SpawnEntityInWorld (.Entity _entity) [0x00000] in <filename unknown>:0
                          at NetPackageEntitySpawn.ProcessPackage (.World _world, INetConnectionCallbacks _netConnectionCallback) [0x00000] in <filename unknown>:0
                          at ConnectionManager.KU (INetConnection , NetPackageDirection ) [0x00000] in <filename unknown>:0
                          at ConnectionManager.Update () [0x00000] in <filename unknown>:0

                          (Filename: Line: -1)

                          No error shows on server.

                          Any information would be appreciated. Thanks!
                          Last edited by xyth; 07-20-2017, 03:07 PM.

                          Comment


                            #58
                            Hi xyth,

                            All my mods are only tested on SP as I don't play much MP. There's a bunch of weird and wonderful rules about syncing MP stuff that I haven't got into yet. From that error message I think I can add something that will prevent it but not sure if it will allow you to pick the arrow up. I'll put it in the next release. I've just fixed another bug where shooting the bear will cause a null ref so there'll be an update at some point soon.

                            Comment


                              #59
                              Thanks. The arrow mod is very "practical" so will be a valuable addition to SDX server mods if you eventually get it working. We (Spider and I) are happy to test any future release candidates.

                              Comment


                                #60
                                Update time!

                                I've changed the way the arrows embed themselves in entities so they should feel less jittery. It's a bit more complicated and is more tied to the entity now so if you hit any NREs post your logs.

                                Cheers,

                                Hal

                                Comment

                                Working...
                                X