Announcement

Collapse
No announcement yet.

Radeon RX 5700 XT - Graphic Artifacts

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    A quick fix for RX 5700 and RX 5700 XT

    Rollback your installation of 7dtd to Alpha 18.1 and download AMD's Adrenalin 19.11.1. It will not show any artifact when starting the game, even in Directx 11.



    Originally posted by Ti2xGr View Post
    Yesterday, in an effort to get a great bang for the buck upgrade from my NVidia GTX 1070, I decided to purchase the Radeon RX 5700 XT. The cost and the specs almost as good as the RTX 2070 Super were my primary reasons for trying it out.

    I got the drivers installed, ran some benchmarks and was thrilled with the results. It ran 4K on Heaven benchmark tests with almost a perfect 60FPS during the test.

    I went to test out my favorite game (7 days to die)... and I could see the improvement right out of the gate...until I started getting screen tearing. I thought...mmm, maybe I'm pushing the card too much? So, I dropped the settings - still artifacts. I tried Vsync options - Still tearing. I tried dropping down from 1080p - still unstable.

    I started searching online for answers and ran into all sorts of other users with artifact complaints with this card in "half their games". The more I searched for answers, the more concerned I became. I tried the tricks of using older drivers (not that there is much). I thought about "waiting it out", but I really don't feel like waiting for my investment to work like it should. I guess that's what you get when you save $100? Not this guy.

    I sent the card back to the seller and ordered a RTX 2070 Super instead (specifically the MSI RTX 2070 Super Ventus OC) as I was able to find it for $500 and change. I'll have to wait a month as the company was backlogged but I'd rather wait for a stable card and my GTX 1070 will do just fine while I'm waiting.

    Why am I sharing this info? I'd like to save someone else the headache of having to go through the process that I did. I'm really disappointed because that Radeon card performed great in my benchmark tests and the graphics were really nice in those. I thought that I had a great card for a great price, but specs and benchmarks aren't what a gaming graphics card are for.

    Comment


      #17
      Originally posted by LucasWee View Post
      Rollback your installation of 7dtd to Alpha 18.1 and download AMD's Adrenalin 19.11.1. It will not show any artifact when starting the game, even in Directx 11.
      I really, really wanted to come here and shoot this down. Unfortunately, I can't. I tried just 18.1, just 19.11.1, and both - the only thing that fixes it is both.

      Worth noting is that the artifacts I'm seeing happen ONLY on roads and underground in dirt. I haven't seen any in sky, grass, trees, buildings, etc.

      So one wonders what changed with roads (asphalt and gravel roads btw) and dirt textures between 18.1 and 18.2?

      Comment


        #18
        Originally posted by bobross View Post
        I really, really wanted to come here and shoot this down. Unfortunately, I can't. I tried just 18.1, just 19.11.1, and both - the only thing that fixes it is both.

        Worth noting is that the artifacts I'm seeing happen ONLY on roads and underground in dirt. I haven't seen any in sky, grass, trees, buildings, etc.

        So one wonders what changed with roads (asphalt and gravel roads btw) and dirt textures between 18.1 and 18.2?
        Hey someone else who is having the same *exact* artifacting problem. I ran into this when I was trying to figure out why asphalt keeps appearing as transparent. https://7daystodie.com/forums/showth...hlight=asphalt

        And now that you mention this, the artifacting I was seeing when I upgraded to my 5700 XT is only on the textures that I can replace the terrAsphalt block with, for example, that do not exhibit the chameleon effect.

        SylenThunder mentions some new system being developed/worked-on and perhaps this is all related in that manner....?

        Comment


          #19
          I am getting the same artifacts on the roads, RX 5700XT, 20.1.1 drivers.

          I hope this gets fixed soon because the gpu works fine in other games.

          Comment


            #20
            O have a RX 5700 and the game crash while I'm on menu changing something, can't even start a game. Vga stop working after a few seconds launch the game.

            Comment


              #21
              Do you play Rainbow Six: Siege by any chance?

              I have an RX 5700 XT and when I used the latest drivers I would always crash whenever tabbing out of Siege.

              I was also unable to play BF4 as the game would crash and freeze my entire PC. But since rolling back to driver version 19.12.1 I haven’t had any of these issues again thus far.

              Comment


                #22
                Originally posted by Sweaty Cam View Post
                Do you play Rainbow Six: Siege by any chance?

                I have an RX 5700 XT and when I used the latest drivers I would always crash whenever tabbing out of Siege.

                I was also unable to play BF4 as the game would crash and freeze my entire PC. But since rolling back to driver version 19.12.1 I haven’t had any of these issues again thus far.
                Wait, are you saying that you're running driver version 19.12.1 on 7 Days Alpha 18.3b4 without artifacting? Or are you only talking about the crashes and/or 18.1 and earlier?

                Comment


                  #23
                  Originally posted by bobross View Post
                  Wait, are you saying that you're running driver version 19.12.1 on 7 Days Alpha 18.3b4 without artifacting? Or are you only talking about the crashes and/or 18.1 and earlier?
                  Sorry I think I may have confused you, when I mentioned rolling back my drivers and it fixing my issue, I was talking about BF4 (Battlefield 4) freezing my pc, which was fixed when I rolled back my drivers.

                  I am on driver version 19.12.1 on the latest version of 7 days to die and I AM getting artifacts.

                  I haven’t tried a different version of 7 days to die.

                  Comment


                    #24
                    Originally posted by Sweaty Cam View Post
                    Sorry I think I may have confused you, when I mentioned rolling back my drivers and it fixing my issue, I was talking about BF4 (Battlefield 4) freezing my pc, which was fixed when I rolled back my drivers.

                    I am on driver version 19.12.1 on the latest version of 7 days to die and I AM getting artifacts.

                    I haven’t tried a different version of 7 days to die.
                    Alright, thanks for clarifying. Worth asking though.

                    Comment


                      #25
                      Yep artifacting is still happening on 18.3 as well. I noticed it only seems to affect the voxel terrain textures for the following:

                      Stone
                      Concrete (the regular kind, not the "see through" kind you can produce in the cement mixer now).
                      Iron Ore
                      Lead Ore
                      Coal Ore
                      Oil Shale [not as noticeable since the artifacting seems to blend with the texture of this ore]
                      Dirt & Topsoil Dirt, but not the biome native topsoil dirt

                      There may be others, but I recall another thread reading about how they changed the texture mapping system and haven't finished porting all of them over yet or something, and perhaps these particular terrain textures are the legacy version?

                      Comment


                        #26
                        Originally posted by bobross View Post
                        Unfortunately, I can't. I tried just 18.1, just 19.11.1, and both - the only thing that fixes it is both.

                        Worth noting is that the artifacts I'm seeing happen ONLY on roads and underground in dirt. I haven't seen any in sky, grass, trees, buildings, etc.

                        So one wonders what changed with roads (asphalt and gravel roads btw) and dirt textures between 18.1 and 18.2?
                        You are having this specific problem, right? https://7daystodie.com/forums/showth...ical-artifacts
                        Happens only on ground textures. Still dying to know why it stopped happening in 18.1 and what causes it.

                        Comment


                          #27

                          As posted in the other thread...

                          Just out of curiosity, what happens to the road textures at night with this issue? All of the videos I've seen are during the day.

                          Would someone with this issue/video card be willing to record a video at night while standing on a road?
                          Extra credit if you show the issue during the day and then use the daytime slider to show night.

                          Schwanz9000
                          Last edited by schwanz9000; 02-06-2020, 06:49 PM.

                          Comment


                            #28
                            Originally posted by schwanz9000 View Post

                            As posted in the other thread...

                            Just out of curiosity, what happens to the road textures at night with this issue? All of the videos I've seen are during the day.

                            Would someone with this issue/video card be willing to record a video at night while standing on a road?
                            Extra credit if you show the issue during the day and then use the daytime slider to show night.

                            Schwanz9000
                            https://youtu.be/Vu2Bj9ZKOgo

                            Comment


                              #29
                              Originally posted by schwanz9000 View Post

                              As posted in the other thread...

                              Just out of curiosity, what happens to the road textures at night with this issue? All of the videos I've seen are during the day.

                              Would someone with this issue/video card be willing to record a video at night while standing on a road?
                              Extra credit if you show the issue during the day and then use the daytime slider to show night.

                              Schwanz9000
                              https://www.youtube.com/watch?v=GHN7the3os8

                              The video shows the bug, shows the current settings, shows how changing terrain detail to low eliminates the bug, shows how any other terrain detail setting (including lowest) resumes the bug, shows the bug at night (with and without a torch).

                              Comment


                                #30
                                Well, what about now? Did you ever solved the problem?

                                Because I've just changed my GTX 1060 6GB to a RX 5700 XT and still have that SAME problem.

                                Did the team of programers already know about that issue of compatibility?

                                Comment

                                Working...
                                X