Announcement

Collapse
No announcement yet.

Dedicated Server - A client which was not in the connected player list disconnected

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Dedicated Dedicated Server - A client which was not in the connected player list disconnected

    Hi guys, I get the following messages when I try to connect to my dedicated server. I have TCP/UDP open from 25000 to 25003.

    Any suggestions?

    A client which was not in the connected player list disconnected. ???
    553.643 OnPlayerConnected 3
    553.667 PlayerLogin: 540431962536577397/AllocatedID: 0/LS|DaWilko/Alpha 9.3
    553.670 Token: FAAAABoPchU22H0Pb4rfAAEAEAEuZSFUGAAAAAEAAAACAAAA4b WlZQAAAABaQAsAAwAAALIAAAAyAAAABAAAAG+K3wABABABstYD AOG1pWUCAKjAAAAAAIaoGlQGWDZUAQDxkQAAAAAAALR+BilFO8 NCLZWhJMKrGw1o5/osoF7sjSAncMI4hdseY3kfF+6k0utl5DbTI3yK/vGKw64g6rQyLjzkOWFliHZm2h5mwy3A9i7vsn3X7SbNp2TulNF gHV1bLX91bMvcwuvTtXCF7R0arCCkQVkJABl2ODe1zdwP6cWlA UtBcdAEAAJwaXhlbHNpbmRlbnQAAAAAAAJ0ZXh0Y2xpY2thYmx lAAAAAAACdGV4dHN0cmVhbWluZGV4AAAAAAABY2xpY2thYmxld GV4dGFjdGlvbgAAAXRvb2x0aXAAAAJzZWN0aW9ucwAAAAAAAmx pbmVoZWlnaHQADAAAAAVUZXh0AAEAAAAAAAgIAFRleHRCbG9ja wACdGV4dGNsaWNrYWJsZQABAAAAAnRleHRzdHJlYW1pbmRleAA AAAAAAWNsaWNrYWJsZXRleHRhY3Rpb24AaHR0cDovL3N1cHBvc nQuc3RlYW1wb3dlcmVkLmNvbS9jZ2ktYmluL3N0ZWFtcG93ZXJ lZC5jZmcvcGhwL2VuZHVzZXIvc3RkX2FkcC5waHA/cF9mYXFpZD0zMDEAAXRvb2x0aXAAAAJzZWN0aW9ucwABAAAAAX N0eWxlAGZyaWVuZHNfY2hhdF9zZWN1cml0eWxpbmsABVRleHQA JQAAAE4AZQB2AGUAcgAgAHQAZQBsAGwAIAB5AG8AdQByACAAcA BhAHMAcwB3AG8AcgBkACAAdABvACAAYQBuAHkAbwBuAGUALgAK AAAACAgAVGV4dEJsb2NrAAJ0ZXh0Y2xpY2thYmxlAAAAAAACdG V4dHN0cmVhbWluZGV4ACQAAAACc2VjdGlvbnMAAAAAAAFzdHls ZQBmcmllbmRzX2NoYXRfaGlzdG9yeQAFVGV4dAAbAAAAVAB1AG UAcwBkAGEAeQAsACAAMgAzACAAUwBlAHAAdABlAG0AYgBlAHIA IAAyADAAMQA0AAAACAgAVGV4dEJsb2NrAAJ0ZXh0c3RyZWFtaW 5kZXgAPgAAAAVUZXh0AAIAAAAKAAAACAgAVGV4dEJsb2NrAAJ0 ZXh0Y2xpY2thYmxlAAEAAAACdGV4dHN0cmVhbWluZGV4AD8AAA ABY2xpY2thYmxldGV4dGFjdGlvbgBzdGVhbTovL3VybC9TdGVh bUlEUGFnZS83NjU2MTE5Nzk3NDkxNTY5NQABc3R5bGUAZnJpZW 5kc19jaGF0X2hpc3Rvcg==
    NullReferenceException: Object reference not set to an instance of an object

    #2
    My config:
    <?xml version="1.0"?>
    <ServerSettings>
    <property name="ServerIP" value="203.147.180.72"/> <!-- External IP address bound here. -->
    <property name="ServerPort" value="25000"/> <!-- Port you want the server to listen on. -->
    <property name="ServerIsPublic" value="true"/> <!-- Should this server register to master server -->
    <property name="ServerName" value="My Game Host"/> <!-- Whatever you want the name to be. -->
    <property name="ServerPassword" value=""/> <!-- Password to gain entry to the server -->
    <property name="ServerMaxPlayerCount" value="8"/> <!-- Maximum Concurrent Players -->

    <property name="GameWorld" value="Navezgane"/> <!-- Navezgane, MP Wasteland Horde, MP Wasteland Skirmish, MP Wasteland War, Random Gen -->
    <property name="GameName" value="My Game"/> <!-- Whatever you want the game name to be THIS CONTROLS THE RANDOM GENERATION SEED -->
    <property name="GameDifficulty" value="2"/> <!-- 0 - 4, 0=easiest, 4=hardest -->
    <property name="GameMode" value="GameModeSurvivalMP"/> <!-- GameModeSurvivalMP, GameModeSurvivalSP (MP has land protection) -->

    <property name="ZombiesRun" value="0" /> <!-- 0 = default day/night walk/run, 1 = never run, 2 = always run -->
    <property name="BuildCreate" value="true" /> <!-- cheat mode on/off -->
    <property name="DayNightLength" value="45" /> <!-- 45 minutes -->
    <property name="FriendlyFire" value="false" /> <!-- Can friendly players damage each other (PvP) -->

    <property name="DayCount" value="3" /> <!-- only for horde mode, use 0 for unlimited -->
    <property name="FragLimit" value="5" /> <!-- only for deathmatch, use 0 for disabled -->
    <property name="MatchLength" value="15" /> <!-- only for deathmatch, use 0 for unlimited -->
    <property name="RebuildMap" value="false" /> <!-- true=map is rebuild on next round, false=not -->

    <property name="ControlPanelEnabled" value="false"/> <!-- Enable/Disable the control panel -->
    <property name="ControlPanelPort" value="8080"/> <!-- Port of the control panel webpage -->
    <property name="ControlPanelPassword" value="CHANGEME"/> <!-- Password to gain entry to the control panel -->

    <property name="TelnetEnabled" value="true"/> <!-- Enable/Disable the telnet -->
    <property name="TelnetPort" value="8081"/> <!-- Port of the telnet server -->
    <property name="TelnetPassword" value="CHANGEME"/> <!-- Password to gain entry to telnet interface -->

    <property name="DisableNAT" value="true"/> <!-- set this to true if your router doesn't support NAT -->
    <property name="AdminFileName" value="serveradmin.xml"/> <!-- Server admin file name -->

    <property name="DropOnDeath" value="0" /> <!-- 0 = everything, 1 = toolbelt only, 2 = backpack only, 3 = delete all -->
    <property name="DropOnQuit" value="0" /> <!-- 0 = nothing, 1 = everything, 2 = toolbelt only, 3 = backpack only -->

    <property name="CraftTimer" value="1" /> <!-- 0 = None (instant), 1 = Normal, 2 = Fast (double speed) -->
    <property name="LootTimer" value="1" /> <!-- 0 = None (instant), 1 = Normal, 2 = Fast (double speed) -->

    <property name="PlayerDamageGiven" value="2" /> <!-- 0 = Very Low 50%, 1 = Low 75%, 2 = Medium 100%, 3 = High 150%, 4 = Very High 200% -->
    <property name="PlayerDamageRecieved" value="2" /> <!-- 0 = Very Low 50%, 1 = Low 75%, 2 = Medium 100%, 3 = High 150%, 4 = Very High 200% -->
    <property name="EnemySenseMemory" value="60" /> <!-- Time, in seconds, that a zombie will pursue something that has been sensed. -->
    <property name="EnemySpawnMode" value="3" /> <!-- 0 = Disabled 0%, 1 = Very Low 50%, 2 = Low 75%, 3 = Medium 100%, 4 = High 125%, 5 = Very High 150% -->
    <property name="EnemyDifficulty" value="0" /> <!-- 0 = Normal, 1 = Feral -->

    <property name="NightPercentage" value="35" /> <!-- percentage in whole numbers -->
    <property name="BlockDurabilityModifier" value="100" /> <!-- percentage in whole numbers -->

    <property name="LootAbundance" value="100" /> <!-- percentage in whole numbers -->
    <property name="LootRespawnDays" value="7" /> <!-- days in whole numbers -->

    <property name="LandClaimSize" value="7"/> <!-- Size in blocks that is protected by a keystone -->
    <property name="LandClaimDeadZone" value="30"/> <!-- Keystones must be this many blocks apart (unless you are friends with the other player) -->
    <property name="LandClaimExpiryTime" value="3"/> <!-- The number of days a player can be offline before their claims expire and are no longer protected -->
    <property name="LandClaimDecayMode" value="0"/> <!-- Controls how offline players land claims decay. All claims have full protection for the first 24hrs. 0=Linear, 1=Exponential, 2=Full protection until claim is expired. -->
    <property name="LandClaimOnlineDurabilityModifier" value="4"/> <!-- How much protected claim area block hardness is increased when a player is online. 0 means infinite (no damage will ever be taken). Default is 32x -->
    <property name="LandClaimOfflineDurabilityModifier" value="4"/> <!-- How much protected claim area block hardness is increased when a player is offline. 0 means infinite (no damage will ever be taken). Default is 32x -->
    <property name="AirDropFrequency" value="24"/> <!-- How often airdrop occur in game-hours, 0 == never -->

    <property name="MaxSpawnedZombies" value="60"/> <!-- Making this number too large (more than about 80) may cause servers to run at poor framerates which will effect lag and play quality for clients. -->
    <property name="VACEnabled" value="true"/> <!-- Enables/Disables Valve Anti Cheat -->

    <!--property name="SaveGameFolder" value="absolute path" /--> <!-- use this to override the default save game path -->
    </ServerSettings>

    Comment


      #3
      I used the following guide and the SteamCMD utility to build the server:
      http://7daystodie.com/forums/showthr...Using-SteamCMD

      Comment


        #4
        I can't seem to edit my posts so, more info in new post

        Running on:
        64bit Windows 2012 R2
        2 X Intel Xeron 2.27Ghz
        8GB RAM

        Comment


          #5
          I am encountering the same error.

          The server is running, telnet and control panel connect. I start the game and it connects, prompts for the password, then sits connecting. Same error :

          A client which was not in the connected player list disconnected. ???
          131.487 OnPlayerConnected 1
          131.505 PlayerLogin: 540431955836504271/AllocatedID: 0/SirMarty/Alpha 9.3
          131.510 Token: <<LEFT OUT>>
          NullReferenceException: Object reference not set to an instance of an object
          156.467 OnPlayerDisconnected 1

          It would seem to indicate that I have a whitelist enabled and I'm not whitelisted, however, this isn't the case. I left the whitelist (and the blacklist for that matter) set to the defaults.

          Anyone know of a solution to this ?

          Comment


            #6
            Done some more reading there seems to be reference to this in the Unity development forums. Unsure if this can assist the devs or mods in resolving this issue.
            http://forum.unity3d.com/threads/net...he-game.78800/

            Comment


              #7
              Ok I've fixed this. Simply, your running Windows Server 2008 or 2012 and your missing the C++ libraries. The game can't function as a dedicated server without them.

              Get them from here:
              x86 - http://www.microsoft.com/en-us/downl...s.aspx?id=8328
              x64 - http://www.microsoft.com/en-us/downl....aspx?id=13523

              Comment


                #8
                Installed C++ on my server also. Working fine. Now to just get rid of the dogs ....

                Comment

                Working...
                X