Announcement

Collapse
No announcement yet.

Tips for Improved Performance on a17 Experimental

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Tips for Improved Performance on a17 Experimental

    TIPS FOR IMPROVED FPS IN 7D2D A17:

    1. When launching the game, press "Show Game Launcher"
    2. When game launcher Window appears, Tick the box for "Show unity screen selector", Also tick "Exlusive Fullscreen Mode"
    3. Press "Run and Save as Default"
    4 When Unity Window Pops Up, ensure "Windowed is UN-Ticked", Select your chosen monitors resolution (or whatever resolution you want to play at)
    5. In the Main menu options, ensure V-Sync is OFF (ive found I lose around 20fps with it on, and up to 30 with it on "Half").

    OTHER Tips
    - Set your screens resolution to whatever you want to play 7D2D at, BEFORE you launch the game
    - If you change ANY settings in game, restart the game
    - DONT use V-Sync, it seems to be poorly optimised at the moment
    - Use F8 key in game to see your FPS
    - In the Game Launcher, instead of Direct X 11, Try GL Core instead, in case you get better results
    - I've found I get best results Full screen, but feel free to test windowed. If it runs like ♥♥♥♥ full screen, ensure "exclusive fullscreen" is ticked in the launcher.

    ----- IMPORTANT ------

    I've found if you do NOT use the "Unity screen selector", despite everything in the options indicating that the game is running at 1080p on my 4k screen, it actually runs at 4k (so performance is hammered).

    The above tips for me got my FPS up from around 32 steady to high 50's, so made a huge difference!

    === My System Specs ===
    i7 6820K (8 Cores)
    16GB DDR4
    500GB PCIE SSD
    GTX 1070
    4K G-Sync Screen (Though I'm Playing in 1080p as mentioned above)
    Last edited by SylenThunder; 12-09-2018, 07:19 PM. Reason: Fixed title. This isn't Beta

  • #2
    Seriously, thank you Bigc90210!!! this made a huge difference on my system, especially in regards to the temperatures my GPU and CPU were hitting, better frame rates, less spikes in FPS...

    Comment


    • #3
      Thanks as well. I had lowest setting and was getting 20 fps near any building. Now i can do smooth 60 \o/

      Comment


      • #4
        All welcome. I've found you can change the screen res without restarting the game, but anything else settings wise always restart I've found. I've also noticed I can set my res to 1080, and occasionally the next time I load the game it comes up as 4k again and I have to set it back. Already reported it to the devs

        Comment


        • #5
          i set up an account just to say thank you it's gone from unplayable 4fps to 60fps !

          Comment


          • #6
            Change your resolution.
            I instantly got 5x as many fps by changing the resolution to the lowest.
            I'm even able to change the textures from 1/8 to 1/2 and still get about the same fps

            Comment


            • #7
              Originally posted by Twila View Post
              Change your resolution.
              I instantly got 5x as many fps by changing the resolution to the lowest.
              I'm even able to change the textures from 1/8 to 1/2 and still get about the same fps
              So what step exactly made you bump the fps ? I can't believe high 50s fps with a godamn gtx1070...

              Comment


              • #8
                Oh my god, THANK YOU for this! My game was running ~100FPS but felt more like 25FPS and I just couldn't figure it out.

                Comment


                • #9
                  ♥♥♥♥in WOW......... 90fps from 50 & it doesnt look wierd & make me wanna puke...... why did that work ? cos ive tried bloody everything & make sure this is posted on steam cos lots are having this issue.... Thanks

                  Comment


                  • #10
                    OpenGL does not work for me, but going exclusive full screen mode, going 1600 x 900, and turning off V-sync did some magic to the performance and made game run lot better. My thanks!

                    Comment


                    • #11
                      So... what resolution would be the recommended for a PC with the following specs?
                      - i5 4690k @ 4 GHz
                      - RX 470 4GB
                      - 16 GB DDR3 @1866

                      I've bought the game a few days ago.

                      A16 was "fine" at fullHD, medium/high settings (I've used the "high" preset but diabled SSAO, AA, Motion blur, DoF and god rays), mostly 60-ish FPS with small hiccups

                      A17 is basically unplayable (below 20 FPS with occasional lag spikes) anywhere near buildings or zombs even after I've lowered the settings to 1600*900 with settings between medium and low.

                      I feel like I "have" to use V-Sync, since AMD's framerate limiter feature does not seem to work and my GPU is trying to melt while dishing out 90+ frames when there are no zombies nearby. Anyways, I still get 30-40 FPS when inside buildings even when it's off, so it does not seem to improve things for me.

                      This is starting to feel a bit ridiculous, as the game's starting to look like something from 10 years ago, and I still can't fight during horde events because it's awfully hard to hit anything with a jumpy 20-ish framerate.

                      Edit:
                      If I'm not a host but delegate this fine role to my friend who has a newer i7 CPU with a 1070 then my framerate problems are gone. My guess as an ex-graphics engine developer that the new A* pathfinding of the zombies is what increases the load so much that my old 4-core-4-threads CPU cannot handle it anymore. Makes sense, as there are lots of possibilities there to be calculated, so the load should be indeed very high.
                      (which is why most games with large mobs use extremely dumb AI-s)

                      Conclusion for other players with old'n'♥♥♥♥ty machines: don't be the host, find one!
                      Last edited by LordyHun; 12-26-2018, 10:13 AM. Reason: I've done some further research into the matter

                      Comment


                      • #12
                        Is there any way to fix (as in hold constant) or elimintate the input lag? I'm playing on a potato computer, playing at lowest settings and still getting random amounts of input lag averaging half a second. I can deal with that amount of lag in a slow-paced zombie game like this, but what I don't like is how sporadic it is.

                        Comment


                        • #13
                          Not sure which setting did it as i changed all of them at once, but this basically doubled my FPS with a GTX1080 at 1440p 144hz

                          Comment


                          • #14
                            You're awesome, these worked for me as well!

                            Comment


                            • #15
                              When is the update planned to be released for download.

                              Comment

                              Working...
                              X