Announcement

Collapse
No announcement yet.

Chunks on land claims resetting completely ruining bases....

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Multiplayer Chunks on land claims resetting completely ruining bases....

    We have had two chunks of land a landclaim was in completly reset in the last two days. It's a dedicated server with no mods.
    Attached Files

    #2
    This may be the reason why we lost 1/4 of our base too, interesting. Can some dev confirm if the land claim block could have been the reason for a chunk reset on server? Our previous opinion was that our chunk reset was due to huge traffic nearby (some screamer farming ... xD, or maybe a bloodmoon horde - but it was all done like 5+ chunks away and way before chunk reset). But I have seen some other chunk resets/odd behaviour on chunk, where (probably) land claim was on server where I play and where I am an admin.

    Edit: Too bad that I did not take screenshots.
    1 chunk reset was our base, where we lost part of it (simmilar to your first screen), I think I had a land claim on that chunk in pillar. Also owner and main admin checked and there was absolutely nothing in the logs, only way to repair it was to load a full server backup, which neither of us wanted, so I just rebuild it using CM.

    Other chunk was where (or rly close near - I did not save a WP on map, but I will ask the player) the entire server saw some other player's land claim on map, which was odd so I went there to check it. Next day the chunk disapered (did not reset - there was a hole down to the bedrock and the chunk was buggy - repaired with "repairchunkdensity").


    Since I play on PvE server not using land claims is an option, but on PvP server it would be rly bad.
    Last edited by Foxley; 01-10-2019, 10:45 AM.

    Comment


      #3
      Hi there. We just had the same issue on our server. We all were out of rendering range and when we returned we had a giant bit of our base missing. Too many items gone. We actually decided to restore a backup and call it a day.

      We placed a bathtub and a corner cabin (added via creative menu) today. May have to do with those? Did you place any of these two items?

      https://i.gyazo.com/d463e8dfde5a93f7...8ba2184a28.png

      https://pastebin.com/ybBLwsDh my client log

      https://pastebin.com/m3ztVYu8 our server log

      Comment


        #4
        No bathtubs where used. We lost tons of stuff as well.

        Comment


          #5
          Nope, no bathtubs. On the 1/4 of base that disappeared was land claim, about 10 chests full of stuff, my bed and small portion of our roof farm.

          Comment


            #6
            I would assume that there is much higher chance of land claim/electricity/high traffic or something like that causing chunk reset, then a decoration that does not do anything, just sits there and has no other function (not saying that it could not be a problem/cause in your case, just that I find it unlikely). And since there is (if land claim causes it) maybe like 5% chance it might be hard to replicate and probably address (we had probably like 30+ active land claims on server during the time and only 2 caused problems? ... and by now 200+ land claims over time - big server with plenty of players and I did not register any other chunk resets). It could also be caused by a combination of factors. Still a big problem for me, I am not gonna use land claims any more - since I think they are causing it (I would rly hate heaving to rebuild part of my huge castle because of a chunk reset and even 1% chance would be too much for me - especially on PvE server where I dont rly need land claim).
            Last edited by Foxley; 01-12-2019, 02:13 PM.

            Comment


              #7
              Portion (~25%) of two bases reset regardless of landclaim block being present

              Myself and a few friends have been playing on this A17 Stable Server, seen quite a few of the known bugs but this is a new one as far as I can tell.
              https://www.gamingalliance.com.au/vi...php?f=74&t=125

              We took a day break (land claim timeout is 14 days) and when one of the guys got on last night we noticed that a 25% vertical slice of two of our land claims had been reset back to the original state.

              Main base reset:
              • Bear Den POI using an allied player's landclaim
                • Within an existing PIO we had been using for a few weeks now
                • Had been extensively changed with full internal remodels as well as a lot of external changes
                • ~25% reset slice in back right of the building can be seen as:
                  • floor colours changing and reset from full kitchen build back to the bear barrels originally there.
                  • missing forges etc
                  • missing storage boxes/safes
                  • groups of spikes missing
                  • Portions of the electrical network
                  • Land claim block itself missing

                • To re-iterate the reset slice included the deletion of the land claim block itself.
                • Building next door had not been reset still very damaged
                • Again approximately 75% of the base was as we left it

              • Garden at the back of the base using another allied players land claim
                • again approximately 25% of the garden was reset with 75% ok
                • Reset seen as missing plants and tilled soil missing and returned to original twigs and forest grassed area
                • depending on which way you look at it/orientation the reset was in the front right corner (using same orientation as the above reset) or back right of the garden area if looking down the 'length' of the garden.....not sure if the land claim blocks were orientated the same way...
                • this time the landclaim was about 10 blocks from the reset area (land claims are 41x41 on server)

              • the land claims are quite close to each other but don't overlap
              • the two reset areas are nearby to each other but not contiguous
              • Doesn't appear to be related to a mission reset as its only a portion of the POI
              • No other reports of this issue on the server. the only thing I'm aware of changing recently is about a week ago some mods were installed, however these mods don't seem related. Details are below for full disclosure.


              Speaking with the server admin they couldn't offer an explanation (no corruption or rollback) and advised raising the issue here as a potential bug.

              The server has recently had a few mods installed but the server admin didn't suspect them as a possible cause and there was no cars nor rocks in the areas that were reset, so that seems reasonable to assume they weren't involved.
              - Car Respawn mod (i will need to place a respawn point for each car)
              - Boulder/Resource Rock Respawn (same with car respawn mod)
              - Bigger Storage (backpacks and Vehicles now have more storage)
              - Daily Trader restock
              - Undestroyable blocks (to be used for bridge ramps due to vehicle traffic causing damage)

              Comment


                #8
                We had similar problem (and few others), I think it was caused by land claim (not sure tho, no official reaction yet) ...

                https://7daystodie.com/forums/showth...-ruining-bases

                Comment


                  #9
                  Yep sound likes the same thing.....I'll add a reference to back here as well to close the loop.

                  Comment


                    #10
                    Saw a similar thing happen to two allied land claims close to each other...in both cases it was one corner that was reset back to the original layout.....one was a POI and one was just in open ground with some bushes and grass there previously. First one had extensive aesthetic and functional changes of the POI with the landclaim block itself being overwritten, while the other just had tilled soil and some plants (Super corn, aloe, and potatoes I think) with the land claim left as is about 10 blocks from the reset edge.

                    So no correlation on any factor really....none that I can see so far anyway. Other than each portion that was reset was about 25% of the whole size....the POI reset was separated from most things as in there was a beginning and end of where it was reset so didn't seem like it was a whole chunk but not sure how large a "chunk" is.

                    https://7daystodie.com/forums/showth...-being-present

                    - - - Updated - - -

                    Thanks Foxley for helping close the loop on the threads!

                    Comment


                      #11
                      Chunk is 16x16 square. In every case I saw so far one chunk just reseted to its original state (= when the map was created). So you are saying that in your case 1 chunk with land claim was reseted and 1 chunk with land claim next to it? I find that interesting, so far I have only seen chunk with land claim on them reset in a17.0.

                      Thanks Tagom for providing more information on this. I would like to add some screens / logs but it happened during christmas and at the time I just thought: Ok, probably to much traffic nearby caused a chunk reset, nvm, happened before, lets just rebuild it and kill zombies away from main base ... well, then a week later I saw Treefart post here and now it seems likely that it is not error type "♥♥♥♥ happens", but an actual bug.


                      Edit: Posted in alpha 17 bug reporting thread.
                      Last edited by Foxley; 01-18-2019, 12:37 PM. Reason: Update

                      Comment


                        #12
                        We have started a new map after the 1st post, now it's happened again. We don't have any land claims close to each other as far as I know. Both spots hit do have allot of things going on, growing, forges, electrical stuff. This is making very hard to enjoy the game.

                        Comment


                          #13
                          Hi, I also play on Tagoms server.
                          I've had about a third of my base reverted back to vanilla. Initial LCB disappeared, I tried to place another it came up as inactive, the second time it worked.
                          The most interesting thing is my roof was covered in solar/battery banks and now while not visible are still providing power to my turrets. As i write this another user has suffered the same fate, the admin. TYVM.
                          20190120055447_1.jpg

                          Comment


                            #14
                            My electricity finally stopped working without the visible solar cells/batts.

                            Comment


                              #15
                              Originally posted by styxs View Post
                              My electricity finally stopped working without the visible solar cells/batts.
                              New update: I placed the solar/battery banks exactly where they where before and they magically filled will battery and cells. I then tried to wire them and received a red console msg about null object. Sorry no screenshot. I looted the banks and will try again after server restart.

                              Edit: Everything works like before.
                              Last edited by styxs; 01-20-2019, 10:01 PM.

                              Comment

                              Working...
                              X