Announcement

Collapse
No announcement yet.

64 Bit Ubuntu Random Crash

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Crash 64 Bit Ubuntu Random Crash

    Hello,

    We recently created a dedicated using Ubuntu.
    The server works fine when using regular maps such as "NavezGane" in serverconfig.xml but not "RWG"

    I've ran some tests and here are the results:
    NavezGane 4092 sometimes work ... sometimes don't
    RWG 4092 Crash (4 players)
    RWG 8184 Crash (4 players)

    RWG 8K map takes about 40 min to generate which is faily good since the server is using an AMD Bulldozer CPU.

    Here are the servers specs :
    CPU: FX6300 6Cores 3.8ghz
    Memory : 16GB DDR3 1333mhz
    Disk : 240gb Kindgston SSD
    Linux Distro : Ubuntu (latest updated desktop version)


    ** Server is running the latest available version (non experimental) of the game. 18.2 B5

    The error message is :
    Aborted core dumped.

    Also, please note that all connected client get two red lines saying "NullReferenceException: Object reference not set to an instance of an object"
    Crash report (pastebin): https://pastebin.com/FhQCejqB


    Thanks for your help!

    #2
    Could you provide the entire log file?

    Comment


      #3
      Hi,

      i have the exact same error on my DEBIAN 10 Server. But for us it came after i reset the map once. Steps i tried to fix it:

      Reset of the Map (Like 5 Times)
      Reinstall of the entire Server using the script from LGSM
      Reboot of the Debian Root Server (2 Times)

      I don't really wan't to reinstall my whole server because other servers are running on it. I even stopped all servers and tested the 7DTD Server but it still crashed. The Log file will be on Pastebin.

      Log File: https://pastebin.com/ApHg8K6K

      Comment


        #4
        I found a fix for this. So after i disabled EAC on my server there were no crashes.

        Comment


          #5
          Yes that is true, BUT, there is still no wayt to generate RWG map without crashing though. That's just weird!

          Comment


            #6
            Originally posted by SylenThunder View Post
            Could you provide the entire log file?
            Absolutely :
            https://pastebin.com/wdtd9qPf

            That a brand new one, i tried to generate an 8K map last night and it still did not work. I always end up with null reference errors and stuff like that.


            As for the random crashes (when using navezgane and not rwg), disabling the EAC worked for us. (We're not worried about cheating since we play with a small group of friends).

            Comment

            Working...
            X