Announcement

Collapse
No announcement yet.

A18.4 b3 EXP bug thread

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UI A18.4 b3 EXP bug thread

    Hallo!

    A18.4 b3 will be on EXP soon!

    We have some localization fixes for you andeven more regular fixes!

    Find the A18.4 b3 changelog here!

    Localization bugs go here.

    For feedback and balancing suggestions, please go to our feedback thread.

    For ideas outside of balancing please visit our dev diary.

    To potentially help with FPS problems:
    #1 lower game's texture quality
    #2 lower AF in driver settings or use "gfx af 0" ingame
    #3 lower game's screen resolution
    #4 lower texture filter settings
    #5 Decrease terrain quality


    Happy Holidays from everyone here at TFP!

    Hated

    Known Issues
    • RWG has some road issues
    • RWG world generation results may vary from PC to dedi
    • Repairing item results in using hands and item
    • Dropped time charges and molotovs are ARMED
    • Stealth goes to 100% when an ally/party member cuts down a tree
    • Game doesn’t shut down properly on PC and Linux after long play session
    • No sound effect when refueling auger and chainsaw
    • Rapid fire with the bow can break its animation
    • Hunting rifle reload can go out of sync
    • Zombies can push the player into the void if they fall on top of the player while in a 1 wide hole
    • Zombies can still dig while doing their pain animation
    • Missing water in POI’s
    • Boats collapse at docks_03 Haulwell Freight Co.
    • Low VRAM GPUs may experience low frame-rates
    • Mac reflections may cause color issues in general or brightness issues on movement
    • Mac: Stun/Bleed may cause overly strong screen effects, please lower intensity of stun/bleed/knockdown in buffs.xml until we can fix it
    • Mac: If you are crashing, please try to disable EAC
    • Linux machines with 8 GB RAM may crash on generating RWG worlds or loading into RWG games
    • Crawlers can’t climb over bars, fences, or any other plate style blocks
    • Crawlers don’t try to hit blocks they can’t climb over
    • Crawlers can hit players on the other side of blocks
    • Leg dismembered zombies can jump up and start walking
    • Leg dismembered zombies that don’t start walking again have a weird climb animation
    • Drawbridge exploit
    • Vehicles placed underground exploit
    • RWG y offset issues
    • High end AMD cards and poor FPS with ultra settings
    • Eyebrows don't change when creating a new character profile
    • Junk turret kills can be hit again to receive double XP
    • Arrows will float after the block they are stuck in is destroyed
    • Switching from ADS to hands with number keys will result in stretched arms
    • Linux mouse wheel is inverted due to a bug with the Unity engine which will be fixed in the next Unity update
    • Spears stuck in world, despawn when player dies and comes back also relogging
    • Shotguns Thanos-snap small and sometimes medium animals
    • Fix for Mac Retina screen tearing MAC Retina
    • Water loss from drugs is not correctly shown in stats screen
    • Larger playermade POI's are not supported at present
    • Removing one bandolier removes the buff
    • Opening your inventory or pushing the sprint button while using a scope removes weapon and hands
    • Larger playermade POI's are not supported at present
    • No sleeper respawn protection for 2nd, 3rd, or Xth land claim blocks
    • Candles show pink for clients





    BUG REPORTING INSTRUCTIONS FOR ITEMS NEEDED WITH ALL BUGS

    OUTPUT LOGS
    Your output log files are in C /steamLibrary/steamapps/common/7Daystodie/7daystodiedata/ you will find a list of logs, the last one being the most recent.

    PLEASE USE PASTE BIN TO UPLOAD YOUR OUTPUT LOGS
    Pastebin how to video, https://www.youtube.com/watch?v=CpTJMIJ1XnQ
    Pastebin link , https://pastebin.com/7wLyjkTT

    SCREENSHOTS and .CSV File
    Please use the following for all screenshots:
    Press F1 to open the console, then type dbs.
    This will open a panel in game for you to type the bug in.
    Once done click OK.
    There will then be a SCREENSHOTS folder in the main 7 days folder containing the screenshot.
    Please upload all screenshots to imgur or other photo sharing site.
    Use the [img]YOUR LINK[/img] tags to post the link as a picture
    There will also be a .CSV file that has all of your perks, books, and schematics listed and needed for testing purposes.

    RWG INFO
    If you generated your own RWG world, please provide the generationinfo.txt from its generated world folder, so we can reproduce this C:\Users\You\AppData\Roaming\7DaysToDie\GeneratedW orlds\yourworld\GenerationInfo.txt



    BUG REPORTING FORM

    Please use this form to report bugs. Testers will then respond. If the form is not used, we will assume you are just chatting to each other.

    COPY BELOW THIS LINE



    Summary: (a short description of the bug)

    Game Version: (A18 b155 / A18.1 bxxx / etc)
    Platform: (PC / Mac)
    OS/Version: (Windows / Linux / Mac)
    CPU Model: (Intel i5 9600K / AMD Ryzen 7 1800x / etc)
    System Memory: (4 GB / 8 GB / 16 GB / etc)
    GPU Model and VRAM: (nVidia GTX 1060 4 GB / AMD RX 580 8 GB / etc)
    Screen Resolution: (width and height)
    Video Settings: (Low / Medium / High / Ultra / Custom (Custom has many combinations, so just list the settings you think are relevant to the bug if any))
    Game mode: (MP host / MP client / SP / Client on dedi, RWG or NAV)

    Did you wipe old saves? (Yes/No)
    Did you start a new game? (Yes/No)
    Did you validate your files? (Yes/No)
    Are you using any mods? (Yes/No)
    EAC on or off?

    Status: NEW

    Bug Description:

    Detailed steps to reproduce the bug:

    1)
    2)
    3)

    Actual result: (description of what is occurring)

    Expected result: (what you expect to occur)
    Last edited by schwanz9000; 02-22-2020, 11:00 AM.

    #2

    Please use the form above and submit your output logs with EVERY bug report no matter how small the bug may be.

    Thanks,
    Schwanz9000

    Comment


      #3
      I set the Max players to 10 and ServerAdminSlots to 4,
      there are 10 players on the server and now no admin can join even though the admin slots have been set.



      PLEASE READ THE NOTES ABOVE BEFORE POSTING

      Client and server output logs and serverconfig.xml files needed.
      Schwanz9000
      Last edited by schwanz9000; 02-08-2020, 11:09 PM.

      Comment


        #4
        Summary: my friend cannot join my local game
        Spoiler: 
        Game Version: A18.4b3
        Platform: PC
        OS/Version: Win10
        CPU Model: Intel i7-8750H
        System Memory: 16gb
        GPU Model and VRAM: nVidia GTX 1060 6GB
        Screen Resolution: 1920x1080
        Video Settings: High
        Game mode: my local game but open to friends when I'm playing

        Did you wipe old saves? No
        Did you start a new game? Yes
        Did you validate your files? No
        Are you using any mods? Yes
        EAC on or off? On

        Status: NEW

        Bug Description: Invited my friend to join my local game, everything seemed to download to his machine ok but when it got up to creating a player my console opened with a red error and his game hung. I could close the console and keep playing, but when I tried to exit the game I just got errors scrolling in the console over the menu, I could still click exit and the game exited. We were both running 18.4b3. Tried with an old game we had both played on under 18.3 and a new game created on 18.4 with the same result. We were sitting next to each other so used a usb stick to ensure we had identical mods folders and I didn't have anything in my prefabs that he didn't. We both reverted to 18.3 stable then tried again with the new game and both got in with no trouble at all.

        Log file is here : https://pastebin.com/fN65Q3Rw
        My friend logs in on line 534 (GrumpyUnclePaul)
        the console line I got was "NullReferenceException: Object reference not set to an instance of an object"
        which first appears on line 575
        I started to exit my game around line 600, the other half of the file is just the recurring error until I managed to exit.

        Expected result: (what you expect to occur) : when I invite a friend to play in my game I expect his machine to download all the setup info and then for him to appear in my game.


        Mod issue. See posts below.
        Last edited by schwanz9000; 02-09-2020, 11:49 AM.

        Comment


          #5
          Spoiler: 
          Originally posted by Grolbu View Post
          Summary: my friend cannot join my local game
          Game Version: A18.4b3
          Platform: PC
          OS/Version: Win10
          CPU Model: Intel i7-8750H
          System Memory: 16gb
          GPU Model and VRAM: nVidia GTX 1060 6GB
          Screen Resolution: 1920x1080
          Video Settings: High
          Game mode: my local game but open to friends when I'm playing

          Did you wipe old saves? No
          Did you start a new game? Yes
          Did you validate your files? No
          Are you using any mods? Yes
          EAC on or off? On

          Status: NEW

          Bug Description: Invited my friend to join my local game, everything seemed to download to his machine ok but when it got up to creating a player my console opened with a red error and his game hung. I could close the console and keep playing, but when I tried to exit the game I just got errors scrolling in the console over the menu, I could still click exit and the game exited. We were both running 18.4b3. Tried with an old game we had both played on under 18.3 and a new game created on 18.4 with the same result. We were sitting next to each other so used a usb stick to ensure we had identical mods folders and I didn't have anything in my prefabs that he didn't. We both reverted to 18.3 stable then tried again with the new game and both got in with no trouble at all.

          Log file is here : https://pastebin.com/fN65Q3Rw
          My friend logs in on line 534 (GrumpyUnclePaul)
          the console line I got was "NullReferenceException: Object reference not set to an instance of an object"
          which first appears on line 575
          I started to exit my game around line 600, the other half of the file is just the recurring error until I managed to exit.

          Expected result: (what you expect to occur) : when I invite a friend to play in my game I expect his machine to download all the setup info and then for him to appear in my game.

          Try this on a new save without all the mods.
          Last edited by schwanz9000; 02-09-2020, 11:49 AM.

          Comment


            #6
            Spoiler: 
            Ok, get back to you shortly

            Edit - ooh, it worked ! Now we start adding the mods back and see which one screws it up I guess - can you see anything that would suggest which sort of functionality is the problem ?


            Mod issue.
            Last edited by schwanz9000; 02-09-2020, 11:50 AM.

            Comment


              #7
              ....


              I've been trying to work on this one.

              Schwanz9000
              Last edited by schwanz9000; 02-19-2020, 10:06 PM. Reason: Could you put this back?

              Comment


                #8
                Summary: The Fireman's Almanac VOL 7 book 5% protection value when wearing a Fireman's helmet doesn't work. Protection values remain the same after reading the book and wearing the Fireman's helmet.

                Spoiler: 
                Game Version: A18.4 b3
                Platform: PC
                OS/Version: Windows
                Game mode: ANY

                Did you wipe old saves? Yes, full wipe reinstall.
                Did you start a new game? Yes, full wipe reinstall.
                Did you validate your files? Yes, full wipe reinstall.
                Are you using any mods? No
                EAC on or off? Off

                Status: NEW

                Bug Description: The Fireman's Almanac VOL 7 book's 5% protection value when wearing a Fireman's helmet doesn't work. Protection values remain the same after reading the book and wearing the Fireman's helmet.


                Detailed steps to reproduce the bug:

                1) Get hit by a Zombie without reading any books AND wearing the Fireman's helmet and check your hp. Note that it has to be a non-bleeding hit and YOU HAVE to be wearing the Fireman's helmet to account for its initial protection value and avoid mistakes.

                2) Heal yourself and read the book. Wear the Fireman's helmet. Get hit by the same Zombie and check your hp.

                In addition, you can unwear it and wear it, or make a pirouette before and after if you are not sure an ancient equiping bug might be reappearing, but the truth is : it is not. No matter how you test, the protection value of the helmet remains the same before and after reading the book, therefore the 5% thing of the book doesn't work.


                Actual result: The Fireman's Almanac VOL 7 book's 5% protection value when wearing a Fireman's helmet doesn't work. Protection values remain the same after reading the book and wearing the Fireman's helmet.

                Expected result: The Fireman's Almanac VOL 7 book's 5% protection value when wearing a Fireman's helmet should work properly.


                Will be asking if the percentage can be increased to make this a little more useful. Thanks!

                Schwanz9000
                Last edited by schwanz9000; 02-13-2020, 10:46 PM.

                Comment


                  #9
                  Summary: Batter Up VOL 2 book's 5% protection value when wearing a baseball cap AND the letter jacket doesn't work. Protection values remain the same after reading the book and wearing the baseball cap And the letter jacket.
                  Spoiler: 

                  Game Version: A18.4 b3
                  Platform: PC
                  OS/Version: Windows
                  Game mode: ANY

                  Did you wipe old saves? Yes, full wipe reinstall.
                  Did you start a new game? Yes, full wipe reinstall.
                  Did you validate your files? Yes, full wipe reinstall.
                  Are you using any mods? No
                  EAC on or off? Off

                  Status: NEW

                  Bug Description: Batter Up VOL 2 book's 5% protection value when wearing a baseball cap AND the letter jacket doesn't work. Protection values remain the same after reading the book and wearing the baseball cap And the letter jacket.


                  Detailed steps to reproduce the bug:

                  1) Get hit by a Zombie without reading any books AND wearing the baseball cap and letter jacket and check your hp. Note that it has to be a non-bleeding hit.

                  2) Heal yourself and read the book. Wear the baseball cap and the letter jacket. Get hit by the same Zombie and check your hp.



                  Actual result: Batter Up VOL 2 book's 5% protection value when wearing a baseball cap AND the letter jacket doesn't work. Protection values remain the same after reading the book and wearing the baseball cap And the letter jacket.


                  Expected result: Batter Up VOL 2 book's 5% protection value when wearing a baseball cap AND the letter jacket should work properly when reading the book.


                  Will be asking if the percentage can be increased to make this a little more useful. Thanks!

                  Schwanz9000
                  Last edited by schwanz9000; 02-13-2020, 10:47 PM.

                  Comment


                    #10
                    Summary: Mac crashing with EAC enabled
                    Spoiler: 

                    Game Version: (A18 18.4 b3)
                    Platform: (Mac)
                    OS/Version: (Mac)
                    CPU Model: (3.6 GHz Intel Core i9)
                    System Memory: (40 GB 2400 MHz DDR4)
                    GPU Model and VRAM: (Radeon Pro Vega 48 8 GB)
                    Screen Resolution: (1920 x 1080 scaled to full screen - 27" iMac)
                    Video Settings: (custom about medium))
                    Game mode: (SP NAV)

                    Did you wipe old saves? (No)
                    Did you start a new game? (Yes)
                    Did you validate your files? (Yes)
                    Are you using any mods? (No)
                    EAC on or off? ON

                    Status: NEW

                    Bug Description:

                    7 days application crashes after almost exactly 20 mins regardless of whether you are at the game menu or playing in a game.

                    Detailed steps to reproduce the bug:

                    1) Start & days
                    2) Wait 20 mins

                    Actual result: Game hard crashes without warning

                    Expected result: Not to crash

                    Output log https://pastebin.com/Ytpf2x9W


                    Thanks for the output log! Will be sending this to the MAC team.

                    Schwanz9000
                    Last edited by schwanz9000; 02-10-2020, 04:55 PM.

                    Comment


                      #11
                      The Bandit voiceover soundnodes have a duplicated offensive soundclip, the MF one:
                      Spoiler: 

                      <SoundDataNode name="malehateattack"> <AudioSource name="Sounds/AudioSource_VO"/>
                      <Noise ID="2" noise="11" time="4" muffled_when_crouched="0.5"/>
                      <AudioClip ClipName="Sounds/VO/Male_Hate/male_hate_attack_01"/>
                      <AudioClip ClipName="Sounds/VO/Male_Hate/male_hate_attack_01"/>
                      <AudioClip ClipName="Sounds/VO/Male_Hate/male_hate_attack_02"/>

                      No need to add extra PottyMouth when kids might be listening :-)

                      And yeah, I know TFP isn't doing bandits yet, but modders are, and you will need to fix that eventually, right?


                      Yeah, I don't think anyone will be looking at this until bandits get their real VO work done. You can always mod it out until then.

                      Schwanz9000
                      Last edited by schwanz9000; 02-10-2020, 04:58 PM.

                      Comment


                        #12
                        High DMG axe doesn't give brass on doorV2's with wasteland book
                        Spoiler: 
                        Expected: You can acquire brass doorknobs from doors that visibly have a brass doorknob (by destroying the door) if you have read the book.

                        Glitch?: If the door is barricaded with the first upgrade (several wooden planks over the door) and your fireaxe is powerful enough to destroy both the barricades/upgrade and the door itself in one swing, it will NOT give you the brass doorknob. The game calculates that you destroyed the first upgrade to the wooden door, but since your fireaxe has also taken out the door itself, it of course doesn't register that you should get a doorknob in return.

                        Don't know if this is a bug or an fyi if you have a powerful fireaxe.

                        Confirmed and Reported. Thanks! Schwanz9000
                        Last edited by schwanz9000; 02-14-2020, 01:02 AM.

                        Comment


                          #13
                          Originally posted by xyth View Post
                          The Bandit voiceover soundnodes have a duplicated offensive soundclip, the MF one:
                          Spoiler: 

                          <SoundDataNode name="malehateattack"> <AudioSource name="Sounds/AudioSource_VO"/>
                          <Noise ID="2" noise="11" time="4" muffled_when_crouched="0.5"/>
                          <AudioClip ClipName="Sounds/VO/Male_Hate/male_hate_attack_01"/>
                          <AudioClip ClipName="Sounds/VO/Male_Hate/male_hate_attack_01"/>
                          <AudioClip ClipName="Sounds/VO/Male_Hate/male_hate_attack_02"/>

                          No need to add extra PottyMouth when kids might be listening :-)

                          And yeah, I know TFP isn't doing bandits yet, but modders are, and you will need to fix that eventually, right?


                          Yeah, I don't think anyone will be looking at this until bandits get their real VO work done. You can always mod it out until then.

                          Schwanz9000
                          I did, I made a modlet called "No Potty Mouth". :-) Thanks

                          HA! Does Trader Rekt say ANYTHING!?!?
                          Last edited by schwanz9000; 02-10-2020, 06:22 PM.

                          Comment


                            #14
                            Summary: EAC times out when downgrading from 18.4b3 to 18.3 stable
                            UPDATE: Updated to OSX 10.14.6, downgraded again, several reboots and 18.3 now playable.
                            Spoiler: 

                            Game Version: (A18 18.3)
                            Platform: (Mac)
                            OS/Version: (Mac)
                            CPU Model: (3.6 GHz Intel Core i9)
                            System Memory: (40 GB 2400 MHz DDR4)
                            GPU Model and VRAM: (Radeon Pro Vega 48 8 GB)
                            Screen Resolution: (1920 x 1080 scaled to full screen - 27" iMac)
                            Video Settings: (custom about medium))
                            Game mode: (MP RWG/Nitrogen)

                            Did you wipe old saves? (No)
                            Did you start a new game? (No)
                            Did you validate your files? (Yes)
                            Are you using any mods? (No)
                            EAC on or off? ON

                            Status: NEW

                            Bug Description:

                            Upgraded to test to see if EAC problem had been fixed. It was not so downgraded to resume normal play. Tried connecting to my normal server and the EAC authentication times out. I uninstalled and reinstalled the game but this did not correct the issue.

                            My gut feeling is that there has been a steam client lib has been updated but the downgrade of 7 Days does not revert it to the older version and is now not compatible with 18.3. Happy to connect with you guys to do more Mac testing if you need it.

                            Output log https://pastebin.com/kqyHrupV - notice the multiple failed assertions.

                            Nice to see that you got it working! Thanks for the Update! Schwanz9000
                            Last edited by schwanz9000; 02-14-2020, 12:21 AM. Reason: Added output log

                            Comment


                              #15
                              Summary: Mac crashing with EAC enabled - Update
                              Spoiler: 

                              Multiplayer server test. Got about 40 mins but still crashed.

                              Output log https://pastebin.com/MzXPrnaP

                              Culprit still appears to be this "Assertion Failed: Using broadcast address on Mac OS X will fail, need to enumerate network interfaces" thing.

                              Also noting that 7 Days App will not cleanly shut down. Have to Force Quit it now.

                              For reference my iMac is connected to my router via ethernet (not using wifi).

                              Hope this helps. This problem is incredibly frustrating.


                              Added this output log to the other one I sent to the MAC team. Thanks again!

                              Schwanz9000
                              Last edited by schwanz9000; 02-11-2020, 04:58 AM. Reason: Additional notes.

                              Comment

                              Working...
                              X