Announcement

Collapse
No announcement yet.

Graphical bug

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Graphical bug

    I playing without mods on servers without mods and not tested this bug in sp since i want only play with friends. When i'm playing game on servers (dedicated or hosted via game doesn't matter) some of buildings may appear like on screenshot (they maybe filled with that block or have some empty spaces). There are also rare variant of this bug (at least in trader buildings), when all doors become blocks with random texture, trader legs "stucks" in block. This is very annoying because i can't notice zombies right in front of me or notice loot on the floor... Reconnect to server helps with this issue at least in area around my "spawn" point, but it takes at least 3 mins so this will be very time consuming and annoying, if i will do it every time.
    Here is what tried to do to fix:
    - Changing graphics quality from low to medium (all post effects disabled, lod distance 100%, water quality low, water particles 0%)
    - Trying to change view distance from low to medium
    - Trying to change object quality and terrain quality to high from low/medium
    - "Verify Integrity of Game Files" in steam
    - Only one things that i not tried is to place something in that blocks for some reasons

    Alpha 18.3
    PC - https://pastebin.com/EakKuXvp
    Screenshot of bug - https://i.postimg.cc/8P8whPwQ/bug.png
    Game logs (idk which one of them with that bug, at least one of them)
    https://pastebin.com/DdqpNRc5
    https://pastebin.com/xLAkBYF7
    https://pastebin.com/B9RxcAWh

    #2
    Hi, I connected to that server and it seemed to run well without any graphical issues.
    So I think you have to delete your local data for the game. The server data will reload
    to your computer.

    Server games save your data here:
    C:\Users\(username)\AppData\Roaming/7DaysToDie/SavesLocal/(string of alpha-numeric
    characters)

    Find the folder for that server by opening the hosts.txt file and looking for the string
    "87.104.40.2:26900". Then delete that folder. When you re-connect to the server,
    it will reload your data.

    Also, maybe it's a mistake, but the server listed in your output log files is a modded
    server. (87.104.40.2:26900).

    Comment


      #3
      I bought another 8gb ram for my PC and did what you suggested. Idk what exactly solved issue, but now i don't saw even single bugged building after ~5h of playing so issue is solved. Thank you for help.

      Comment


        #4
        I have suffered this issue in my own server played locally - And its identical as it was in the screenshots OP provided. If I had to describe what I think it is - its the POI's distant LOD (Like, far far distant, when hundreads of blocks away so its in the horizon) POI model - what you see when its a very small object before getting closer, however its occuring when your close or even inside the POI. As a note this did not effect my friend on the same server, he had a completely fresh install and this may be important. Additionally on another none modded server did not have this issue despite my game locally had loaded with old mods and old modded POI's - but this was navezgane instead of RWG.

        Describing the issue...Fake walls you can walk through if you break the blocks or covering none-cube block shapes with full cubes, Fake blocks inside open/broken doors, walls in half-broken blocks like the burnt frame remains, slightly rotated cubes inside smaller objects/blocks (or larger ones) based on the size of a model (Imagine a trash can or pile of cinder blocks with a small rotated 45 degree metal cube sticking out midway of it, Or a pallet with a blue tarp that has a large stone cube covering almost all of it but where the blue tarp sticks out) - Pre-existing holes in outer walls cause blocks to appear inside the POI, but generally it covers the outer walls and does not tend to appear inside the POI. It feels like a simplified outer model is overlapping the actual blocks in game, with attributes based on what it is (an external stairwell is for instance a line of thinner flat blocks). The type of block its simplifying presumably for distant vision based on material, size and rotation.

        I used my alpha 17 server files and updated it with steamcmd to alpha 18.4 b4 stable using a new seed and server config file. It originally had a lot of modlets but all were moved out (and thus disabled) before starting the server for the first time, and all previous RWG generations and save files removed. the config files had slight edits yet the only thing that remained from previous changes were the POI files assuming they will do no harm (Old ones would be updated, modded ones not used).

        From another thread that sounded immensely similar on its second half, I think it may actually be somehow linked to old modded POI files or old servers/clients having leftover POI data of some form - even though the config files were not in any way using them so they shouldn't have spawned anything modded (I hadn't changed/added them in there, as I understand random gen it only uses what is specified in its POI groups).

        https://forums.7daystodie.com/forum/...oading-in-game

        I don't see anything special with logs, and my servers edits are only loot groups / experience requirements and zombie range (Honestly, nothing I tweaked manually was graphical, blocks or world gen) so I don't think its a question of the configs folder which were effectively fresh 18.4 b4 stable configs with those small tweaks.

        A rejoin of the server cleared them up once in a POI I was standing inside - but it reappeared within half an hour running about 600-1000 distance in game.

        Maybe there some file the game generates/keeps that could be old, and is not a file sent through steam (and thus not updated) and could have old versions of it that do not work properly?

        Some small side notes:
        • 32GB's of installed ram, few background programs running
        • A GTX 970 (3.5GB's graphical memory with an additional slow 512MB's)
        • 6 physical 12 logical core processor running around 3.8Ghz~ / thread.
        • Server on same machine
        • World size was 8192x8192 RWG - System still had spare memory to allocate though and it ran fine performance wise.
        • was using 3.1GB's vram and under-utilizing the hardware generally, game running decently at 58 frames/sec so I don't believe it is a resources issue
        • Graphics drivers were very recently updated within a week or two, running nvidia driver version 442.50
        • I had validated my game files, to no avail, restarts and rejoins had it simply come back, but often only in distant locations
        • changing graphics settings had zero effect on the issue after trying so many combinations

        I will when I next go to play likely try removing then redownloading fresh copies of the POI files for the server and my own client. - if it clears it up then I will edit and note it here.
        Last edited by nilanthanimosus; 3 weeks ago.

        Comment

        Working...
        X