Announcement

Collapse
No announcement yet.

windows freeze crash after loading game on direct x (windows crash: 0x00000113)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    windows freeze crash after loading game on direct x (windows crash: 0x00000113)

    My freshly installed new pc freeze crashes just after loading the game(it reaches main menu then crashes, or crashes as soon as i click while still loading/showing the fun pumps logo), looking into the windows crash dump file it gives a 0x00000113
    looks like direct x crashes, usually the windows crash file points to watchdog.sys and ntoskrnl.exe as well as dxgkrnl.exe.
    I have added system information, output file of the game and windows crash files.

    I dont have this problem with any other software or using the glcore or vulkan option in the 7 days launcher.
    However Glcore runs very badly on my system including flickering grey pixels.
    Vulkan runs great but crashes to desktop regularly.
    I also didnt have this issue on another system.

    7 days output log: https://pastebin.com/UhKJgjR4

    system info: http://speccy.piriform.com/results/A...wbpKQ2eV7xsdMb

    I have tried solving this issue by reinstalling drivers, the game, directx itself, deleting and or disabling the anti cheat and changing launch options in steam to no avail.
    The same crash occurs.


    Attached Files

    #2
    At a guess, you didn't install your GPU drivers after installing the PC. Windows drivers don't support the DirectX features the client needs.

    Also since you have the 5700, be sure to check the threads on the issues with that GPU.

    Comment


      #3

      From your output log, it says SteamAPI_Init() failed which is an indicator that Steam is not running.

      Your speccy shows
      Stopped:Steam Client Service in your services section.

      This doesn't make any sense if GLCore and Vulkan work.


      Schwanz9000
      Last edited by schwanz9000; 4 weeks ago.

      Comment


        #4
        i definitely installed the latest drivers, as i said in my first message i also tried reinstalling.
        I checked the other output files and with GLCore there is no steam error:
        2020-02-25T12:50:24 0.010 INF [Steamworks.NET] SteamAPI_Init() ok

        I don't get any error message from steam, or i cant see it (yet) because the system freezes, including sound, which loops half a second of audio or something, but no bsod.
        I don't know the correct terminology for this kind of crash, but i have seen it in the past before with other systems, usually bad hardware.

        Comment


          #5
          Originally posted by Achilex View Post
          I don't know the correct terminology for this kind of crash, but i have seen it in the past before with other systems, usually bad hardware.
          Since it's a new build I'd start with stress testing the hardware. Run Memtest, prime95, and furmark for a bit and see how it performs. Install
          hwinfo as well to check temps etc. while testing.

          There's been reports of 5700 cooler mounting pressure issues so I'd check gpu temps carefully.

          Edit: All that said, I suspect a driver issue since it's only Directx. I'd try uninstalling with DDU and reinstalling the video driver.
          Last edited by Beelzybub; 4 weeks ago.

          Comment


            #6
            Edit: All that said, I suspect a driver issue since it's only Directx. I'd try uninstalling with DDU and reinstalling the video driver.
            Ok I used DDU in safe mode to clean the system of driver software and reinstalled the stable amd driver version 20.1.3 also while disabling the internet to prevent updates to no avail.
            I still have the exact same problem.
            Hardware stress test is going to take a while and i highly doubt the problem is in the actual hardware, but if you insist it, i will try.
            I have played other games like GTA 5, NMS, L4d2, and EU4 without any problems at all.

            Output log seems the same, do you need to see the new crash dump and 7days output log?

            Also tempratures are fine all over, my video card is not the stock version, its an Asrock challanger
            Last edited by Achilex; 4 weeks ago.

            Comment


              #7
              Yes, with Direct X enabled, please send a new output log and a speccy report.

              Schwanz9000

              Comment


                #8
                Originally posted by Achilex View Post
                Hardware stress test is going to take a while and i highly doubt the problem is in the actual hardware, but if you insist it, i will try.
                I'd never insist, merely recommend.

                Comment


                  #9
                  Thx for looking into this bug so quickly, i really love the game and i'd like to be able properly play it.

                  Also, AMD just released new drivers, i will be installing them today.
                  Apparently the 5000 series had quite a few specific bugs.
                  If this update doesn't work i will also report it to the amd bug team with links to this forum.

                  These crashes occurred on the stable version of 20.1.3

                  7 days output:

                  https://pastebin.com/CMCjhDQe
                  https://pastebin.com/nX8Ms9B6

                  Windows mini dump:

                  https://pastebin.com/7WSLVx6G
                  https://pastebin.com/NwcFYZBx

                  Comment


                    #10
                    Updating the drivers to the latest version didnt help.

                    Sometimes the game and windows fail to make a log/crash dump file, or only partial.
                    What is weird is that clicking the left mouse button will sometimes reboot windows and induce the crash earlier.

                    I also played around with forcing the game to run on older dirtect x versions, which didnt help either.
                    a few weeks ago i also tried reinstalling the game and the experimental version, no difference noted.

                    https://pastebin.com/F1PdsyNM
                    https://pastebin.com/JAq7bdAV

                    Edit: i reproduced the bug a few times and noticed one crash file successfully going through the steam initialization, still it crashed, didn't notice any difference. The crashes i get in vulkan are known, correct? It clearly states not fully implemented. any chance it gets fixed/fully implemented anytime soon?
                    It runs alot better then GLcore which kind of looks worse, has much lower fps and stutters and also some flickering graphics bugs on stone and roads.

                    https://pastebin.com/AVEJJxnS

                    Last edited by Achilex; 4 weeks ago.

                    Comment


                      #11
                      So, It crashes the computer causing a reboot with DirectX, but will run without crashing using GLCore?

                      Comment


                        #12
                        Originally posted by Beelzybub View Post
                        So, It crashes the computer causing a reboot with DirectX, but will run without crashing using GLCore?
                        Yes, GLcore runs without crashes. But as mentioned, it runs poorly.

                        Comment


                          #13
                          Just making sure: When you freshly installed your system, did you copy over anything from your old PC or install, for example your users directories? If yes, that could also have copied over old 7d2d settings.


                          Comment


                            #14
                            Originally posted by meganoth View Post
                            Just making sure: When you freshly installed your system, did you copy over anything from your old PC or install, for example your users directories? If yes, that could also have copied over old 7d2d settings.

                            no, fresh install on a new ssd.

                            PS: I forgot to post a new speccy report http://speccy.piriform.com/results/r...46Qs7wPtnUQMCs
                            Last edited by Achilex; 4 weeks ago.

                            Comment


                              #15
                              Is this issue being addressed? I will gladly provide any further information if necessary.

                              Comment

                              Working...
                              X