Announcement

Collapse
No announcement yet.

Graphic Glitches when Nvidia ShadowPlay is turned on.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Graphics Graphic Glitches when Nvidia ShadowPlay is turned on.

    Hello, when NVidia ShadowPlay (that shadow recording mode) is turned on, i get heavy graphic glitches when spawning in a world / on a server, also when alt-tab out and back in and when running in windowed mode.

    The game runs fine after i hit apply in the video settings. until i alt+tab out and in again.

    This started to happen in a late a13 update (cant remember which), but now in 14.5 i figured out whats causing it.

    Well, i dont think its nvidia's problem since this only happens to me in 7dtd.
    Other games, including games made in Unity works fine.

    My system is:
    MSI GTX 980Ti with 364.72 WHQL driver and 2.11.2.55 geforce experience / shadowplay
    Windows 10 x64
    Intel xeon e3-1241v3
    4x4gb ddr3-1333 Ram which 7dtd is using 3.5 to 4gb.
    game, steam and windows on sepperate ssd's


    Recently ran several test programs to make sure its not the hardware. Well other games works fine except 7dtd.

    i also noticed that my and other players got chrome / metallic texture when the game bugs out.
    https://picload.org/image/rgdogprr/20160423191059_1.jpg
    https://picload.org/image/rgdogpra/20160423191126_1.jpg

    Without shadowplay i still get fps drops until i hit apply button, even after alt-tab.
    Last edited by gamerpaddy; 04-23-2016, 06:05 PM.

    #2
    Originally posted by gamerpaddy View Post
    Hello, when NVidia ShadowPlay (that shadow recording mode) is turned on, i get heavy graphic glitches when spawning in a world / on a server, also when alt-tab out and back in and when running in windowed mode.
    Heh, Looks like the T-1000 (Terminator 2)

    I run with shadowplay, I have never had the issue your pics display, I only ever run in fullscreen though. (I have a GTX950, running the same driver version)

    You mentioned it happens in window mode, do you find you get the same problem if you run fullscreen ?

    I'm guessing you run with your 7D settings on ultra?

    Comment


      #3
      Oh well, the graphic glitches came back even without shadowplay.

      sorry for that misleading title, since it seems to be fixed after disabling shadowplay, but well. they came back.

      see video what happens in Fullscreen mode.
      In windowed mode it just keeps glitching even when hitting apply.



      normally im running at medium to high, dont want to waste much power in long sessions.
      but chaging it back to low or ultra doesnt help.


      i also noticed that this bug only happens on public servers. never had it in a local game / singleplayer.

      Also in a local game, i dont have that Terminator player skin

      Comment


        #4
        Not fixed, THIS METHOD DIDNT WORKED FOR LONG
        as it turns out, i still had old settings.

        Deleting all registry entries in HKEY_CURRENT_USER\SOFTWARE\The Fun Pimps\7 Days To Die fixed the issue. now the game runs as it should.

        Please make the settings accesible trough documents folder like any other games out there.
        dealing with registry is just not right.

        can be closed
        Last edited by gamerpaddy; 04-25-2016, 07:02 PM.

        Comment


          #5
          So, the method above didnt fixed it at all.
          It just ran for a few hours straight, but then the issues came back.

          Weird situation.

          Heres my output log:
          http://pastebin.com/UWrS6Kkp

          as lot of

          Code:
          RenderTexture error: failed to retrieve color surface [unknown error, code 0x1]
           
          (Filename:  Line: 379)
          
          RenderTexture creation error: CreateTexture failed [out of VRAM]
           
          (Filename:  Line: 90)
          VRAM is looking like this:

          in this order:
          1. Game Start ( little spike, around 450mb.)
          2. joined the game (around 4500mb)
          3. hit apply (decreased to 1400mb)
          4. lag spike (1500mb)
          5. lag spike (1600mb)
          6. lag spike (1700mb)
          7. alt tab out and in ( 4500mb )
          8. quit game (460mb)


          Mods loaded: ItemIconTest (bunch of png files). Same issue without mod.

          Comment


            #6
            got exactly same problem... one think I noticed is when I join server that has only few people like 10 or less
            everything works like a charm... no graphic issues... and then when I join server with 15+ people or people
            just start to join server... FPS goes down... and I have to do option's / video settings and then apply... then
            I am back to normal fps... around 100 or so... but player skins are now messed up just like in video up there.

            Comment


              #7
              Oh finally someone having the same problems. i tought my hardware is broken or something.

              i just tried to use the stable_u52 (unity 5.2) 14.5 client but the game get graphicglitches then crashes when connecting to a a server.
              i also noticed that i dont get these glitches if there are few players on the server, like you described. above 10-15 it gets worse.

              had the same problem in alpha 13.x on a unmodded server.

              some weird thing i noticed, when the game stutters and apply wont fix it, hold some dirt in your hands and quickly rotate it. this removes the lagg until you stop rotating it.
              Also got "somtimes" stuttering on certain sounds, like smg shots.

              Comment


                #8
                So was anyone able to find solution for this ? I am starting to think it has something
                to do with Win10... because when you alt tab to windows and then alt tab back to
                game it is not all black again... graphics are still messed up but you at least get menu
                icons back and are able to go to options menu video and press apply, witch fixes FPS
                and terrain issues but player skins become metallic/chrome/black textured.
                I tested it further... and for me it only happens when more than 15 players online.

                Running on:
                Win10 x64
                I7-4770K
                Nvidia GTX970

                P.S. Tried to delete registry... tried to do full game reinstall, different drivers,
                Nvidia shadowplay on/off ... steam overlay on/off... tried to mess with nvidia 3d
                settings, but nothing seems to help.
                Next step full OS reinstall... will test it on same PC with fresh Win7 OS... will get
                back to you all with results.

                Comment


                  #9
                  still got the same problems in 14.6
                  evem in stable_u52 and running the game as windows 7 compatibility.

                  Windowed mode now works partially. well when i click apply it works, until i alt-tab out. heavy graphic glitches. player model taking random textures.

                  Comment


                    #10
                    I found solution to this problem, all you need to do is go to Video Settings and put your texture quality to half,
                    and keep it that way, you wont notice much difference in graphics quality but you will no longer have FPS
                    drop's or black/flickering textures.

                    Comment

                    Working...
                    X