Announcement

Collapse
No announcement yet.

Alpha 9.1 Spelling errors and bad filenames causing prefab not to load in random gen.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Mechanics Alpha 9.1 Spelling errors and bad filenames causing prefab not to load in random gen.

    In hope that the TFP will see this:

    There are spelling errors and bad filenames causing prefabs to fail to load in random gen.

    DJNOOB found two spelling errors in the xml files for the army camps. Wilderness is misspelled as wildreness and burnt_forest is mispelled as bunt_forest.

    Tohuwabohu found all the prefabs that begin with business mispelled as buisness in the prefabs.xml file in the random gen folder.

    I found a space between the 2 and the extension in the files "housetanpyramid2 .tts" and "housetanpyramid2 .xml" that was causing an error statement in the console. The space was probably in there since alpha 1 but did not matter until random gen came out. Once the space is eliminated, the error goes away.

    The post can be found here:
    http://7daystodie.com/forums/showthr...ndom-Gen/page3

    #2
    Good post... amazing all the typo's in this quick release.

    Comment


      #3
      Originally posted by JohnBob View Post
      In hope that the TFP will see this:

      There are spelling errors and bad filenames causing prefabs to fail to load in random gen.

      DJNOOB found two spelling errors in the xml files for the army camps. Wilderness is misspelled as wildreness and burnt_forest is mispelled as bunt_forest.

      Tohuwabohu found all the prefabs that begin with business mispelled as buisness in the prefabs.xml file in the random gen folder.

      I found a space between the 2 and the extension in the files "housetanpyramid2 .tts" and "housetanpyramid2 .xml" that was causing an error statement in the console. The space was probably in there since alpha 1 but did not matter until random gen came out. Once the space is eliminated, the error goes away.

      The post can be found here:
      http://7daystodie.com/forums/showthr...ndom-Gen/page3
      The better option for the housetanpyramid2 is to add the space in prefabs.xml for random gen. If you delete the space from the 2 filenames, you also need to correct prefabs.xml for Navezgane. (fix in one spot random gen prefabs.xml versus fix in 3 places {rename 2 files and change one xml}).


      I detailed out all the fixes in this post:
      http://steamcommunity.com/app/251570...21584532313664

      Comment


        #4
        I agree. It is easier to change the prefabs.xml file in random gen than to change the file names and the prefabs.xml in Navegane.

        I was just going through the prefabs in random gen to fix the asphalt replacing railing problem with a 1 row and/or 1 column buffer with objects at the border of the prefab when I noticed there are two decoration entries for house_new_mansion_02

        <decoration type="model" name="house_new_mansion_02" />
        <decoration type="model" name="house_new_mansion_02" />

        Shouldn't this be

        <decoration type="model" name="house_new_mansion_02" />
        <decoration type="model" name="house_new_mansion_03" />

        Comment


          #5
          These spelling errors cause the following messages on a dedicated server launch with Random Gen:

          Could not load prefab 'housetanpyramid2'. Skipping it
          Could not load prefab 'buisness_red_brick_01'. Skipping it
          Could not load prefab 'buisness_red_brick_02'. Skipping it
          Could not load prefab 'buisness_red_brick_03'. Skipping it
          Could not load prefab 'buisness_red_brick_04'. Skipping it
          Could not load prefab 'buisness_red_brick_05'. Skipping it
          Could not load prefab 'buisness_red_brick_06'. Skipping it
          Could not load prefab 'buisness_red_brick_07'. Skipping it
          Could not load prefab 'buisness_tan_brick_01'. Skipping it
          Could not load prefab 'buisness_tan_brick_02'. Skipping it
          Could not load prefab 'buisness_tan_brick_03'. Skipping it
          Could not load prefab 'buisness_tan_brick_04'. Skipping it
          Could not load prefab 'buisness_tan_brick_05'. Skipping it


          I'm just adding this post so the error is searchable and this thread comes up.

          Comment

          Working...
          X