Announcement

Collapse
No announcement yet.

Mini Bike bug will eventually cause your server to lag-out and crash.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Crash Mini Bike bug will eventually cause your server to lag-out and crash.

    If a player loses his mini bike in the ground or it disappears you may begin hearing a bugged sound such as headlight clicking on and off over and over again. Sometimes its the motor revving which will not stop. The server will become laggy to all your players and your CPU (server side) will spike to 70% and higher eventually crashing the server. The only way so far we have been able to fix the problem is to destroy all the blocks around the minibike which will take about a half an hour. During this time lag will be server wide almost unplayable for your players. As your players begin to obtain and use the minibike more server owners will begin to see this happen. If anyone out there has a better fix then destroying the blocks around the bike, please let me know. The fix we use can only be done by admins flying under the ground to free the bike. Devs need to patch this as soon as possible or this will become a massive server killer. I have nearly 5,000 hours play time, and this is the first true server killer bug I have seen.

    #2
    There are SERIOUS ISSUES with the Mini Bike!

    Originally posted by Albino View Post
    If a player loses his mini bike in the ground or it disappears you may begin hearing a bugged sound such as headlight clicking on and off over and over again. Sometimes its the motor revving which will not stop. The server will become laggy to all your players and your CPU (server side) will spike to 70% and higher eventually crashing the server. The only way so far we have been able to fix the problem is to destroy all the blocks around the minibike which will take about a half an hour. During this time lag will be server wide almost unplayable for your players. As your players begin to obtain and use the minibike more server owners will begin to see this happen. If anyone out there has a better fix then destroying the blocks around the bike, please let me know. The fix we use can only be done by admins flying under the ground to free the bike. Devs need to patch this as soon as possible or this will become a massive server killer. I have nearly 5,000 hours play time, and this is the first true server killer bug I have seen.

    Each and every mini bike we have made has either disappeared or fallen through the ground.

    For example, my friend and I took our mini bikes out. We stopped on the side of the road to loot. I came back and transferred my inventory to my bikes inventory. I left again to continue looting. Came back and my mini bike was gone but my friend’s bike was still there. We had padlocks on both bikes. I couldn’t see my bike but when searching for it I could see the words “empty mini bike”. I tried to action it and was able to collect my inventory out of it. I got on my friends bike to ride back to base and about halfway there I fell through the map on the bike. I’m an admin on the server so I tried to teleport myself to the surface. I tried control-right clicking on the map, didn’t work. I got off the bike, bike disappeared, then I was able to teleport myself out.

    The 3 other mini bikes we made disappeared too. It would show “empty mini bike” for a few days on the spot where the bike had been. You can’t place a frame or anything else on that spot. The bike is still there, it’s just invisible. You can hit it with a pick and it makes the sound of hitting it. After a server restart, the invisible bikes were gone.

    Comment


      #3
      I still have invisible mini bike frames around our server even after a restart.

      Comment


        #4
        Additionally if a player gets sucked under the ground with the bike he is stuck! If he leaves the server he will get back in but not past the loading screen he can still access inventory ect but all he sees is the start screen. Fishing around with the cursor you can find and exit the game. When the player is in the server it causes scrolling errors in the console panel and starts to lag the server. The admins can not kill him or teleport to him because of the scrolling console. I was in a server I was not admining and the owner gave me temporary admin so i could fly out. As soon as I teleported myself out the server went back to normal.

        Comment


          #5
          Caution, several ghost minibikes in one area caused region files to reset, thus loosing base! Remember to keep backups, because they are very bad when invisible!

          Comment


            #6
            there are two invisible indestructible minibikes in my compound now. They are driving all of us a little insane. Some of my users claim massive FPS drop when anywhere near these bikes, others don't have problem. I myself am getting massive stuttering around the bikes on a core i7 with a gtx 980. Does anyone have any suggestions? I don't want to reset the region files because weeks of work.

            Comment


              #7
              ya, I have two ghost mini bikes parked where I was trying to assemble them... and few days later... the ground is starting to get Very glitchy.
              a strip of land the width of a road and two city blocks long opened up, total void that ate buildings and allowed you to see underground blocks.

              hours later that glitch disappeared... I'm blaming the two minibikes that disappeared... I'm not going to destroy the blocks below them yet... as I'm hoping for a "fix"... and it took EONS to collect the parts.

              Comment


                #8
                I was going create another thread, but after searching for minibike I found this on page 6 - it's the closest to what we experienced a couple of days ago.

                TL;DR Minibike fell down to bedrock and got stuck inside a steel block. This caused the entire server (around 20 people on at the time) to lag out, with players reporting a drop to 3 FPS. Tracking down the minibike with with "le" command, removing all parts and eventually the frame instantly resolved the issue. Minibikes are now banned on the server.

                Longer story:
                Server started lagging heavily and all players reported severe frame drops. We restarted the server and for the first minute it was fine. Then suddenly the lag kicked back in. Eventually through a process of elimination we found when a particular player logged in, the frames would gradually (over about a minute or so) go down from 60 FPS to 3.
                Once we identified the player, we asked him to leave and join a couple of times - both times the frames would almost instantly go back up to 60 FPS and then drop down again when he joined.

                A player gave a Reddit link which described the symptoms almost exactly like we were experiencing it. (If I find the link again, I'll edit this post and put it in). It said that minibikes can cause this issue.

                So, I got the player to login and immediately teleported him away from the area - FPS went back to normal.
                The next morning when only a few players were on I went back to the area and FPS instantly dropped again. I used "le" when I was close enough for the bike to spawn, went to the coordinates and found it stuck inside a steel block. I had to remove the parts first before I could pick up the frame. Issue went away instantly.

                The TL;DR makes it seem simple, but it took hours to work through this and it would suck to go through this process again.

                I managed to capture the log client side and it shows this message being repeated hundreds of times:

                Code:
                2016-04-20T06:21:12 604.884 INF Time: 9.81m FPS: 60.84 Heap: 583.2MB Max: 672.6MB Chunks: 629 CGO: 552 Ply: 4 Zom: 0 Ent: 5 (6) Items: 0 CO: 1
                2016-04-20T06:21:28 620.503 INF Executing command 'cm'
                2016-04-20T06:21:42 634.884 INF Time: 10.31m FPS: 57.84 Heap: 595.6MB Max: 672.6MB Chunks: 630 CGO: 576 Ply: 4 Zom: 0 Ent: 5 (6) Items: 0 CO: 1
                Ran out of virtual channels. Sound will not be played.
                 
                (Filename:  Line: 314)
                Ran out of virtual channels. Sound will not be played.
                (Filename:  Line: 314)
                Ran out of virtual channels. Sound will not be played.
                (Filename:  Line: 314)
                Ran out of virtual channels. Sound will not be played.
                (Filename:  Line: 314)
                Ran out of virtual channels. Sound will not be played.
                etc etc......
                Here is the complete log file for reference:
                output_log.txt
                Note: The file was much larger, but I removed a ton of the repeat error message so it was within forum size limits.

                Comment


                  #9
                  Hrm, just noticed this thread is in the fixed section. I'll wait a couple of days and if there are no responses I'll create it under a new thread in the main Bug Reports section.

                  Comment


                    #10
                    Originally posted by Albino View Post
                    If a player loses his mini bike in the ground or it disappears you may begin hearing a bugged sound such as headlight clicking on and off over and over again. Sometimes its the motor revving which will not stop. The server will become laggy to all your players and your CPU (server side) will spike to 70% and higher eventually crashing the server. The only way so far we have been able to fix the problem is to destroy all the blocks around the minibike which will take about a half an hour. During this time lag will be server wide almost unplayable for your players. As your players begin to obtain and use the minibike more server owners will begin to see this happen. If anyone out there has a better fix then destroying the blocks around the bike, please let me know. The fix we use can only be done by admins flying under the ground to free the bike. Devs need to patch this as soon as possible or this will become a massive server killer. I have nearly 5,000 hours play time, and this is the first true server killer bug I have seen.
                    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
                    you could just access it's inventory and dis - assemble the bike
                    Last edited by quailgg94; 05-01-2016, 06:33 PM. Reason: more info

                    Comment


                      #11
                      I thought this was a new issue with the mini bike. Funny that this is in fixed when it's nowhere near that. It's also funny that there are more vehicles making their way in when the original vehicle is so ridiculously bugged that server owners are banning the use of them. Maybe wanna fix the problem with the mini bike instead of introducing other vehicles that use the same system? Sounds like a good idea to me but, what do I know? I'm just a forum pleb.

                      Comment


                        #12
                        in 14.6 the minibike spawns ontop if it detects being under the map. also all bikes that has been lost over the days, now spawn ontop or 1-2 blocks in ground (warning message in console)

                        the stuck in ground one actually causes fps drops if youre near.

                        Comment


                          #13
                          Yeah why is this reported fixed? This issue is not localized to a few instances. It is on every dedicated server that allows minibikes. On most, the bikes are banned entirely!

                          Comment


                            #14
                            Found this thread just a couple of minutes ago.
                            I had the same issues with this bug. I mentioned them in this thread:
                            https://7daystodie.com/forums/showth...-unplayability

                            Here is a simple guide to solve the issue, but it is time consuming:
                            1. Locate the bike by using the "le" console command. If a player is near the bike, framerates will drop and the bike will be visible in this list as an entity. This also means, there is no framerate drop if no player is near the bike with this problem.

                            2. As soon as you have found the position via the "le" command, write the position down and ask all players to leave the server.
                            If nothing helps, kick them with "kickall"

                            3. Move your own player to the position of the bike. You can compare your position with that of the bike by the same command "le".
                            If you have NPCs around you (animals, zombies etc.), you can kill them by the "killall" command, this will empty the list to you and the bike, making reading the position easier.
                            The 1. value of the position is in -west to +east direction. If you move west, the value decreases, if you move east, the value increases.
                            The 2. value is the altitude of the player.
                            The 3. value is the position is in -north to +south direction. If you move north, the value decreases, if you move south, the value increases.
                            Teleporting to the same values would be the fastest way, but i don't know if there is a teleporting command in the vanilla unmodified version of the game. You can teleport by using the map in creative mode, but it's not that precise.

                            4. If you are at the position of the bike or one or two blocks away from it, try to access its inventory. If you can do this, just dismantle the bike. The last part of the bike can be took off, by holding the "e" button and choosing the "hand" symbol. The bike might be invisible.
                            If you have dismantled the bike completely, everything should be fine again. Framefrates should be back at normal level.

                            5. If you can't access the bikes inventory, you will need to dig down to the bike. I don't know a command to turn of collision mode to get under the surface without digging.
                            If you have reached the bike, repeat step 4.


                            These steps are acceptable as quick and dirty solutions on servers with only a view players. Typically the none public servers.
                            If you have a public server and a lot of players logging in and out, the best solution is to turn off the minibike on the server.

                            Comment

                            Working...
                            X